Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu version is 12.04.3. My computer is a Asus laptop, UL30Jt with a Nvidia graphics card. I previously had problems getting the graphics drivers to work, but I resolved that previously today. Afterwards I attempted to reboot and it worked fine, then I installed glfw and afterwards it won't start the gui after restarting.

I am not completely sure, but I think it was after I installed glfw, and it's dependencies xorg-dev and libglu1-mesa-dev.

Pressing ctrl + alt + f1 brings up the terminal where I can login.

I tried running for example glxinfo, which just prints:

Error: unable to open display.

I tried running glxinfo previously, when I was trying to figure out my driver problems nad it printed .. information of some kind. (Different from this error message, I dont remember what it was.)

I have been using Ubuntu for about 4 months, so I am not terribly experienced with different useful commands.

I have looked at this without finding anything useful.

startx gets a fatal error:

Fatal server error: no screens found

sudo service lightdm start or sudo start lightdm just takes me back to the blinking underscore, and pressing ctrl + shift + f1 takes me back to the terminal.

I tried running sudo apt-get install nvidia-current (which installed a bunch of stuff) and then rebooting which had no effect.

This also happened the last time I tried to install glfw, I don't know if it is the actual cause, but it has happened after attempting to install glfw twice in a row now. The last time I got the error message "could not write bytes broken pipe", however this time I don't get that. I fixed it by reinstalling Ubuntu, but it would be painful to have to do that again.

share|improve this question
    
did you try sudo rm /etc/X11/xorg.conf? –  Avinash Raj Dec 12 '13 at 2:45
    
Now it skips over the flashing underscore and goes directly to the terminal, but still can't get any gui. –  Martin Dec 12 '13 at 10:54

1 Answer 1

Run run the below commands in the virtual console,

sudo rm /etc/X11/xorg.conf
sudo service lightdm restart
share|improve this answer
    
if it won't works then try startx command. –  Avinash Raj Dec 12 '13 at 11:15
    
sudo service lightdm restart just takes me back to the blinking underscore. startx gives fatal server error: no screens found. –  Martin Dec 12 '13 at 11:47
    
run the first command and then restar your pc. –  Avinash Raj Dec 12 '13 at 12:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.