Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run the command sudo sublime from my terminal, it opens the program but will not allow me to run any other commands in my terminal until I close sublime text. This doesn't work because I'm trying to run tests from the terminal while making changes to my project on sublime text.

Right after Sublime Text opens from the terminal, I get this error:

(sublime:3522): IBUS-WARNING **: The owner of /home/mitch/.config/ibus/bus is not root!

I have tried figuring out what that warning means but have gotten no where. I'm very new to Ubuntu and appreciate any insights.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Option 1:

  • Open a new terminal tab or a new terminal.

Option 2:

  • Try:

    gksu sublime &
    

    The & tell the terminal not to wait for the program to finish.

share|improve this answer
    
The second method didn't work unfortunately :( I could open a tab, but i'm more wanting to find out why its giving me the IBUS warning and how to fix the problem instead of working around it. –  Mitch Glenn Dec 11 '13 at 23:58
    
Try running with gksudo (or gksu) not sudo this should set up the environment variables properly. –  Julian Stirling Dec 12 '13 at 0:01
    
Awesome, I had to install gksu and now when I run gksu sublime & it stops the hanging. Thank you! –  Mitch Glenn Dec 12 '13 at 0:07
    
Great. I have edited the original so it is clear to others! –  Julian Stirling Dec 12 '13 at 0:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.