Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm am a new user to Ubuntu. I installed Ubuntu 12.04 LTS 64 bit on my laptop. Nothing went wrong with the installation. The problems seems to remain in a video card driver, as I have done my bit of research, and nothing really worked so far.

I am using a NVIDIA Optimus card and yes, I know that optimus card are not supported by nvidia or something, GeForce 610M to be exact (not certain).

At boot instead of the Ubuntu splash screen it opens a black screen for a few seconds (not sure, maybe up to a minute) saying something along the lines of:

"Cannot initialize agpgart module
DRM: Fill_in_dev_failed"

I am also not very experienced. So please forgive me for not knowing how to post directly what the error is. If you guys tell me it's important I'll try to type it on a paper and then update this post.

As far as I'm aware, I've tried using nomodeset, installing Bumblebee and/or Nouveau, and it seems hard to fix. Instructions pointing me to undo any possible mistakes I might have done would also be appreciated.


Also asked on another board, they told me I should post here the translated results for sudo lshw -C display

it returned:

PCI (sysfs)
*-display UNCLAIMED
details: VGA compatible controller product: 3rd Gen Core processor Graphics Controller manufacturer: Intel Corporation physical id: 2 bus id: pci@0000:00:02.0 version: 09 length: 64 bits clock: 33MHz capabilities: msi pm vga_controller cap_list conffiguration: latency=0 resources: memória:f1000000-f13fffff memória:e0000000-efffffff ioport:4000(tamanho=64)

EDIT2: Fixed after removing nomodeset from the grub options and updating the kernel. TugaTech burning board, seriously advise its use...

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.