Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Same issue in Banshee, Rhythmbox, VLC, and even some (but not all) videos from YouTube, etc. in Chromium. It seems to be strongly related to how many other things are happening on my computer - the more stuff (compiles, lots of apps open, etc.) the more pops. Highly compressed MP3 files seem to be the worst. I even got some short squeals like sliding a needle across a record sideways. It happens with FLAC files just a little bit, but much, much less.

If I open the MP3 file in Audacity, then play, it works as well as a FLAC file. So, I'm getting some popping in the audio stream, but 3-10 times as much when it has to convert from MP3. The FLAC popping settles down after maybe 10 seconds. It still pops maybe a few times a minute for a few minutes before playing perfectly fine (or maybe I get used to a very low level of popping?).

Adding "tsched=0" to the end of the "load-module module-hal-detect" line in /etc/pulse/default.pa had no effect. I just upgraded to Ubuntu 13.10 - it worked fine in 12.04.

My guess would be a gstreamer or alsa issue, or possibly hardware. If it were hardware, I'd think MP3 vs. FLAC wouldn't matter. I'd also guess it has something to do with not filling enough of a buffer before trying to play the sound. Else why would it get better the longer music is playing?

share|improve this question
1  
I similar problems in a new system I just built with 13.10. I tried many suggestions that didn't work. Then I disabled (uninstalled) pulseaudio and went to just running Alsa and have not had problems since. –  jwernerny Dec 13 '13 at 16:14
    
@jwernerny That solved my problem, but it also uninstalled ubuntu-desktop and with it, the little speaker-icon sound indicator in the little tray at the top. –  GlenPeterson Dec 19 '13 at 13:25
    
This got my sound indicator back: sudo apt-get install indicator-sound and kill the panel to get that to take effect killall unity-panel-service thanks to: ubuntuforums.org/showthread.php?t=1871144 –  GlenPeterson Dec 19 '13 at 13:36
    
Oh, I also had to go to the sound settings and choose the right sound card once everything else was done. –  GlenPeterson Dec 19 '13 at 13:43
    
Well, the problems didn't really go away completely. I noticed that alt-tab between windows sometimes made the popping go away - particularly with Chrome. It definitely got worse the more Chrome windows I had open. Chrome just upgraded in the past couple of days and my sound seems to be much better - maybe it's all fixed now? –  GlenPeterson Feb 3 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.