Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to setup my Dell XPS 15 9530 to use dual monitors in Ubuntu 13.10. The machine has the Optimus chipset with an Intel 4th generation card and an nVidia GeForce GT 750M.

I followed the instructions on the Bumblebee tutorial (https://wiki.ubuntu.com/Bumblebee), but am stuck trying to actually get the nvidia card working and dual monitors to be detected. (Note: right now clicking on "detect displays" does not detect the monitor in my mini-displayport that windows detects. HDMI is not an option at the moment, although the port does exist)

When I try to set the nvidia-settings the following happens:

$ optirun nvidia-settings 
[   77.278444] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.
[   77.278495] [ERROR]Aborting because fallback start is disabled.

The Bumblebee tutorial discusses this and says to edit /etc/bumblebee/xorg.conf.nvidia and change the bus of the nvidia card. I have done this, and it still doesn't work. Please see the output below:

$ lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

Contents of /etc/bumblebee/xorg.conf.nvidia (ignoring comments):

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    BusID   "PCI:02:00.0"

    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
EndSection

As far as I can tell, I have set the BusID correctly, but the card still doesn't work. I also tried installing nvidia-current from the ubuntu-x-swat/x-updates ppa, but this did not fix anything.

Does anyone have any suggestions as to how I can get this thing working? Please let me know if there is any more information that I can provide.

Thank you for your help!

share|improve this question
    
Here are some notes that might help (although slightly outdated): zachstechnotes.blogspot.com/2012/01/… –  OSE Dec 11 '13 at 16:35
    
@OSE Thanks for the link. I tried some of the suggestions in the blog post, but my setup seems to be somewhat different; for example, I can't change any BIOS settings related to Optimus (turning it off/on etc). –  HerrKevin Dec 12 '13 at 7:51

1 Answer 1

up vote 2 down vote accepted

I spent a day doing this specifically on the XPS 15 9530. I finally got it working after looking at many different (and conflicting) sources. I started a write-up on it, which outlines how to get it to work. It is still a work-in-progress, but I hope the guide will get it working for you. As of right now, this guide covers it up to the point of getting Bumblebee to work. I have not done the multi-monitor setup yet, but I figure this will get you closer.

http://wiki.belmankraul.com/linux/mint16_bumblebee

share|improve this answer
    
Thanks for your guide! That worked for me, not only to get bumblebee working, but multiple monitor support is now working on my mini-display port! (the HDMI port "works", but has issues even in Windows). Just one comment, in your guide you write: sudo gedit /etc/bumblebee.conf but this should be /etc/bumblebee/bumblebee.conf Other than that everything is correct. Thanks again. –  HerrKevin Dec 19 '13 at 21:25
    
I'm glad that worked for you. Thanks for pointing out the mistake. I have corrected it. Sadly for me, I ended up having to go with Windows 8.1 after all. My setup required both the HDMI and mini-Display port, and I had other issues using Ubuntu, mainly because of the UltraHD resolution. I am hoping better support will come in the next year or so. Let's say I am using windows temporarily... –  bkraul Dec 21 '13 at 4:38
    
I have both the hdmi port and miniDP port working right now on my 9530. I don't really have any issues at all (ok, like once a day the HDMI port will blink the monitor black for a half second). I don't actually have the NVidia card working right now, it's just running off the haswell integrated graphics, but it works fine for desktop applications (I don't really game much anymore, sadly). I started installing bumblebee but never really got that far, so I don't think that influences anything. –  Nate Finch Jan 31 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.