Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my netbook from UNR 10.10 to Natty 11.04 and it was working fine till I decided to install Unity 2D. After installing Unity 2D I tried to give it a spin and logged out of my session. When I tried to log back using Unity 2D, I got just the background. There are no panels and no dock. All my icons are missing. Though I know that it is working because I can execute commands using keyboard. Now I am trying to reset unity by opening terminal and entering:

unity --reset

However, this works, but only till I have the terminal opened. As I close the terminal, it goes back to square one and I am looking at the background with no panels.

There is one more thing, this is happening only in one profile. My other user profiles are working fine and I can access and work in them absolutely fine.

I believe I have messed up my graphic card settings for my admin profile. I am not sure which graphic card it has (I am using Acer Aspire One D250 Netbook).

Please Help !

Here is the output of the Unity --reset command:

unity --reset
unity-panel-service: no process found
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Initializing core options...done
Window created on XQueryTree, map state isViewable? 1
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 1
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 1
Window created on XQueryTree, map state isViewable? 1
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Window created on XQueryTree, map state isViewable? 0
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing mousepoll options...done
Initializing vpswitch options...done
Initializing animation options...done
Initializing snap options...done
Initializing expo options...done
Initializing move options...done
Initializing place options...done
Initializing grid options...done
Initializing gnomecompat options...done
Initializing wall options...done
Initializing ezoom options...done
Initializing workarounds options...done
Initializing staticswitcher options...done
Initializing resize options...done
Initializing fade options...done
Initializing unitymtgrabhandles options...done
Initializing scale options...done
Initializing session options...done
** (<unknown>:1698): DEBUG: Unity accessibility initialization
** (<unknown>:1698): DEBUG: Shows on edge: 1

Screen geometry changed:
  Monitor 0(primary)
   0x0x1024x600

unity-panel-service: no process found
** (<unknown>:1698): DEBUG: PanelController:: Added Panel for Monitor 0
Initializing unityshell options...done
** (<unknown>:1698): DEBUG: MaximizeIfBigEnough: Gnome-terminal window size doesn't fit
** (<unknown>:1698): DEBUG: PlaceEntry: Files & Folders
** (<unknown>:1698): DEBUG: PlaceEntry: Applications
** (<unknown>:1698): DEBUG: PlaceEntry: Commands
** (<unknown>:1698): DEBUG: /com/canonical/unity/applicationsplace
** (<unknown>:1698): DEBUG: /com/canonical/unity/filesplace
** (<unknown>:1698): DEBUG: Setting to primary screen rect: x=0 y=0 w=1024 h=600
** (<unknown>:1698): DEBUG: Acquired the name com.canonical.Unity.Launcher on the session bus

** (<unknown>:1698): DEBUG: TrayChild Rejected: gst-keyboard-xkb gnome-settings-daemon Gnome-settings-daemon
** (<unknown>:1698): DEBUG: TrayChild Rejected: nm-applet nm-applet Nm-applet
** (<unknown>:1698): DEBUG: TrayChild Rejected: gnome-power-manager gnome-power-manager Gnome-power-manager

(<unknown>:1698): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
** (<unknown>:1698): DEBUG: IndicatorAdded: libapplication.so
** (<unknown>:1698): DEBUG: IndicatorAdded: libsoundmenu.so
** (<unknown>:1698): DEBUG: IndicatorAdded: libmessaging.so
** (<unknown>:1698): DEBUG: IndicatorAdded: libdatetime.so
** (<unknown>:1698): DEBUG: IndicatorAdded: libme.so
** (<unknown>:1698): DEBUG: IndicatorAdded: libsession.so
Setting Update "run_command_terminal_key"
Setting Update "fullscreen_visual_bell"
** (<unknown>:1698): DEBUG: TrayChild Rejected: update-notifier update-notifier Update-notifier
** (<unknown>:1698): DEBUG: TrayChild Rejected: update-notifier update-notifier Update-notifier
** (<unknown>:1698): DEBUG: TrayChild Rejected: update-notifier update-notifier Update-notifier
share|improve this question
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Dec 31 '11 at 23:28
add comment

closed as too localized by Marco Ceppi Dec 31 '11 at 23:46

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Try the following:

CTRL + ALT + F1

This will open a text TTY1

Login

type

unity --reset-icons &

CTRL + ALT + F7 watch while your screen flickers and then unity launcher icons should be reset

then

CTRL + ALT + F1 type

unity --reset &

CTRL + ALT + F7 watch while your screen flickers and unity launcher + compiz should be reset

If this doesnt work, try creating a new administrator account and copy any important files from the old to the new.

If the Users and Groups windows doesnt work - try the following command line entries:

sudo adduser newusername
sudo usermod -a -G admin newusername

obviously change "newusername" for the name of your new account.

share|improve this answer
    
tried that and it got my panel and its icons back (and I didnt need the running terminal anymore too).. but it only remain till the session is on.. once I restarted.. it was back to the same condition ! –  Swapnil Narendra May 1 '11 at 20:23
    
Swapnil - You mentioned this affects only one account and the other accounts are OK. Try the ideas here to rename the hidden folders in your duff account: askubuntu.com/questions/38518/natty-broke-my-graphics/… –  fossfreedom May 1 '11 at 20:42
    
didnt work either :(( –  Swapnil Narendra May 1 '11 at 21:03
    
Perhaps just create another admin user account - copy any data files from the old to the new account and delete the old one? –  fossfreedom May 1 '11 at 21:07
    
I read that advice of your in that other question and I tried this.. but it is weird that I am unable to add any account right now.. have tried rebooting as well but no luck.. also.. if it helps, I see something like this in TTY, "ubuiquity-gtkui.desktop file is missing" is it related to my problem ?? –  Swapnil Narendra May 1 '11 at 21:19
show 2 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.