Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


I am trying to install Ubuntu 13.10 amd64 on a Lenovo M91P thinkcenter. But every post install boot ends up with 1962: No OS found. I want to keep just Ubuntu as the only OS on the host (previously running Win XP SP3)

This is what I have done so far:

  1. Intially I tried installing the server OS (since thats what I wanted). Previously the station was running Win XP proff SP3. Saw the issue for the first time.

  2. Did some googling to come across Ubuntu UEFI help articles - Tried both trial and error and install in EFI mode using Ubuntu Gnome 13.10. No good

Basically, I have tried to install from "Try Ubuntu" option of live DVD also, both retaining and erasing the existing partitions, but no improvement.

Below is the boot repair summary link

BootRepair summary run from Live DVD of the current state

Any help will be highly appreciated.



share|improve this question
I ran dmesg | grep EFI from Live session and the following is the output [ 0.000000] efi: EFI v2.00 by American Megatrends [ 3.617179] fb0: EFI VGA frame buffer device [ 4.007326] EFI Variables Facility v0.08 2004-May-17 [ 5.644428] fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver – Soumik Dec 11 '13 at 11:00
It looks to me like you need to partition your disk again so that you have a root directory. at the moment you've got no bootloader so the system can't boot. Check out threads on how to partition your drive for ubuntu only and try doing that. – comrademike Dec 11 '13 at 12:28
The computer does have boot loader files -- they're on /dev/sda1. The computer has an EFI, not a traditional BIOS, so the computer booted in EFI mode and the Ubuntu installer set up an EFI-mode boot loader on /dev/sda1. This is perfectly normal on an EFI-based computer; however, some EFIs are buggy and there are still bugs on the Linux side, too, so it doesn't always work. There's also a root (/) filesystem defined, but it's inside the LVM setup. Again, this is not an error. – Rod Smith Dec 11 '13 at 23:30

I have three main suggestions:

  • Upgrade your firmware. You may have a buggy EFI that's causing problems. Sometimes upgrading will solve the problem; however, upgrading alone may not be sufficient -- you may need to jump through some extra hoops, like re-installing or doing the next two steps.
  • Boot an emergency system in EFI mode and run the Boot Repair tool. This can fix many such problems. You may need to use the advanced menu and select the option to back up the Windows boot loader file and copy GRUB in its place. (I realize you don't have Windows, but some EFIs are badly broken and look for its boot loader.)
  • Try my rEFInd boot manager. You can try the USB flash drive or CD-R version risk-free. If it works, install the Debian-package version in Ubuntu. If that works, you're done; but if not, boot into Linux using the CD-R or USB flash drive and then try using the alternative naming options.

You can try these things in any order that you like.

share|improve this answer

I went back to legacy boot mode, set up the MBR GRUB and Ubuntu is running fine. Good for me, I didn't require dual boot, going by what you say.

I did try Boot Repair (only the recommended fix), but it was no good.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.