Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem occurs with Ubuntu Classic desktop not Ubuntu Classic (No Effects) desktop.

The windows bear some similarity to maximised windows under the new Unity desktop where the top border merges with the bar at the top of the screen. I can't stop this effect. Launching a new window causes it to appear at the top left of the screen with no top border so I can't move it to expose the window below.

I have read the post of a similar problem with a netbook under 10.10 where the culprit is a program called maximus. I have tried to find it in the list of processes by ps augx | grep maximus but it is not there; neither does it appear in the list of start up programs nor the list of current processes in the system monitor. So I guess it is not maximus that is causing the problem.

share|improve this question
    
Can you move the window by pressing alt and dragging? –  RolandiXor May 1 '11 at 21:34
    
No I can't. It works in Unity, though. Also, in Classic desktop, I get a resizing cursor but it won't resize. I am really stuck with windows that appear at the top left, on top of one another, without top border and without moving or resizing capabilities. –  nigeldodd May 2 '11 at 8:38
    
That tells me that in classic mode some application (possibly a window decorator) is not starting. Can you tell me if compiz is running during a classic mode session? –  RolandiXor May 2 '11 at 14:13
    
Problem is solved. Thanks Roland for asking whether compiz is running. I went into compiz settings and disabled everything and then started enabling things one by one. I am fairly sure that I had Composite, OpenGL and Expo enabled and by de-selecting Expo the problem went away. Now all three are enabled and the problem has still gone away. I am sorry I do not have a more reasoned and articulate account of cause and cure. –  nigeldodd May 2 '11 at 17:50
    
well I guess I should post an answer so this can be marked solved :P –  RolandiXor May 2 '11 at 20:32

1 Answer 1

Ensure that compiz is running in your classic mode session and that your plugins (including window decoration) are correctly configured.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.