Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 installed in my HP laptop with pre-installed Windows 8. I created partition with three drive, c, E and F. I started and entered boot setup and selected from Flash drive Ubuntu. Select the third option, "Something Else". I selected the third dive (F). I freed up space from this disk. Then created three partition for ROOT, SWAP AREA and HOME. I also created a partition from the again freed up space of 700 MB and gave it for "Device for boot loader installation". Then clicked "Install Now".

After everything is about to be finished, got a fatal error saying "Device for Boot loader cannot be used". So, I gave another drive namely, /dev/sda/ATA.... Then Got a message saying installation is completed and asked me to restart the computer. When I restarted it, did not see any options given for starting Ubuntu at the start up. But, when I log in to Windows I can able to see two partitions created namely, G and H with the same size as of ROOT and HOME. If I click on that partition , Windows ask me "Whether I want to format the disk"?

I want to know whether Ubuntu is installed or Not? I am 80% sure it is not? If it is not installed can I run the installer again. Will the previous formatted disk can be used up. Or will it be possible for me to merge partitions (G and H) back to F before running the installation again? I am trying with 12.04, should I need to try with higher versions? Will these partition and merging within a drive (F) which is 99% empty, will create any problems? Will that part of memory will become unusable? or Shall I use First option while "Installing Ubuntu"?

Sorry for the rumblings, really I don't have clue how to deal with this?

share|improve this question
    
You have to disabled UEFI from your BIOS. See if this works. –  user220402 Dec 11 '13 at 5:26
    
I tried resintalling this time got no errors during installation. But after restarting I don't see system for which os to choos? any help is welcome –  user223967 Dec 11 '13 at 5:59
    
you may have to press a key (often 'esc') to enter the boot menu as the machine starts up. –  comrademike Dec 11 '13 at 12:41

2 Answers 2

  • Boot ubuntu live-disk,then install gparted.Delete all the partitions where ubuntu is installed, and combine all into one.Then reinstall ubuntu on that partition.
share|improve this answer
    
I don't have optical disk drive. will the space be useful, if I delete the current ones and merge them? –  user223967 Dec 11 '13 at 4:04
    
you can try ubuntu live-usb or gparted-live-usb.Yes the space will be usefull if you delete the current ones and merge them. –  Avinash Raj Dec 11 '13 at 4:06
    
I tried resintalling this time got no errors during installation. But after restarting I don't see system for which os to choos? any help is welcome –  user223967 Dec 11 '13 at 5:01
    
it directly boots into which os? –  Avinash Raj Dec 11 '13 at 5:13
    
Windows. The Secure Boot option in my BIOS is having "Disabled" Value –  user223967 Dec 11 '13 at 6:00

Thanks for all of your support. The issue is resolved. I just installed ubuntu 13.10 in the same partitions. That made it works fine. But every time, i need to enter Boot options and then select from Hard Drive option. It then shows me options of Ubuntu.

Thanks, Santhosh

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.