Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed this tutorial to have Ubuntu automount an external USB drive onto the system. I added this line to /etc/fstab:

UUID=885025e1-09a5-3f29-90f6-5d07668be59b /media/Backup hfsplus rw,user,suid,uid=1000,gid=1000,umask=000 0 0 

After rebooting the machine, I navigated to /media/Backup. The drive showed up, and I could browse its contents, but I wasn't able to write to it (even as root). I'm on Ubuntu Server 12.04.3.

How can I automatically mount the drive and be able to write to it, ideally as a normal user?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

HFS+ file systems with journaling by default can only be mounted read only on Ubuntu. You will either have to disable journaling on the drive or force the read-write mount (the latter could be dangerous). Please read this for detailed instructions for both solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.