Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm tryiing to solve some missing icons and styles in my AWstats static pages.

I'm running an Ubuntu 12.04 server with several virtual hosts. Below is the default apache2 config (/ect/apache2/sites-available/default) and in the default awstats.conf I have set the icons dir to "/awstatsicons".

Despite all this, when I try to open any of them straight in the browser (by following a link, for instance - http://www.example.com/awstatsicons/other/awstat_icon6.png) I get an error 404.

Could you help me, please?

    Alias /awstatsclasses/ /usr/share/awstats/lib/
    Alias /awstatsicons/  /usr/share/awstats/icon/
    Alias /awstatscss/ /usr/share/awstats/css/
    ScriptAlias /awstats/ /usr/lib/cgi-bin/
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    <Directory "/usr/share/awstats">
            Options +Indexes +MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all
    </Directory>
</VirtualHost>

I have set the owner of /usr/share/awstats to www-data:www-data and the permissions to 775.

share|improve this question
    
Please post the entries of error.log and access.log of your unning apache while accessing the URL. –  chaos Dec 11 '13 at 6:37
    
Hi, chaos, I tailed both logs and then tried opening one of the "missing" icons in a separate browser tab, but there appeared no new entries in either error.log or access.log. –  zkvvoob Dec 12 '13 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.