Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was making some changes in CCSM and I activated "rotate cube" plugin which asked me for resolving some conflicts & disabled all of them but with 11.04 something related to Unity were also disabled. I tried to restore it to defaults and then it all got screwed up.

And now if I am using the new Unity login, I just end up with my desktop, stuff on desktop and a mouse cursor.

I am able to go to terminal (tty) Ctrl + Alt + F1 but I am not sure what I need to do to fix it. I want the settings to be what they were on a fresh install.

share|improve this question
    
doesn't alt-f2 work either? By the way, i think you can log in from a live cd and delete the compiz folder from your home folder. –  Chriskin May 1 '11 at 16:51
    
Alt-f2 depends on panel service, I believe so none of the shortcuts were working. Thanks, I have solved the issue by resetting both Compiz & Unity. –  Ashfame May 1 '11 at 17:38
    
It does? it works for me even when unity has crashed and i have no panels around. Anyway, the important part is that you solved it –  Chriskin May 1 '11 at 17:58
    
yeah! may be shortcut listener is still running after crash, not sure. –  Ashfame May 1 '11 at 18:06

2 Answers 2

up vote 4 down vote accepted

To restore Compiz to default settings, try typing this into the terminal you have open:

gconftool-2 --recursive-unset /apps/compiz-1

To reset Unity to it's default settings, type:

unity --reset
share|improve this answer
    
Will this work in tty1? I can't open a terminal in tty8 –  Ashfame May 1 '11 at 16:51
    
Great! That did it. Can you please correct your command though? It should be /apps/compiz-1 –  Ashfame May 1 '11 at 17:35
    
Cool I'm glad! And thanks :) –  Lee Jarratt May 1 '11 at 18:07
    
@Lee jarratt you added an extra dash –  Ashfame May 1 '11 at 18:09
    
Just edited it :) –  Lee Jarratt May 1 '11 at 18:22

Had the same exact problem.

What solved this for me was to re-run ccsm and re-enable the Ubuntu Unity Plugin (can be found under the "Desktop" category), telling it to disable every conflicting feature if prompted to.

share|improve this answer
    
how do I get to CCSM? I am ended up with just a desktop without any panels –  Ashfame May 1 '11 at 16:51
    
can you open a terminal somehow? If yes - run "ccsm" from there, if not - try running it from Ctrl+Alt+F1, setting the DISPLAY variable to :0.0 or whatever your display is. –  yonix May 1 '11 at 16:52
    
I was able to run CCSM with ccsm --display :0 and enabled Unity plugin but panels didn't show even after a reboot. I have resolved the problem though. –  Ashfame May 1 '11 at 17:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.