Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm getting this massage ever login in my Ubuntu OS.

the Message "Your disc drive being checked for errors. This will take some time."

followed by this message "checking.. 3%" progress.

Press C to cancel.

What is the problem in my disc? is it normal for all Ubuntu os? is there any issue?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Every so often (More or less after 30 reboots) your hard drives will be checked bu the system. This is normal. Does not mean your hard drive has a problem, it is just routine for the system to make sure everything is ok.

If you do a man fstab there is a part that talks about the sixth field of the fstab file in /etc/fstab which says:

   The  sixth field, (fs_passno), is used by the fsck(8) program to deter‐
   mine the order in which filesystem checks are done at reboot time.  The
   root  filesystem  should  be specified with a fs_passno of 1, and other
   filesystems should have a fs_passno of 2.  Filesystems within  a  drive
   will  be checked sequentially, but filesystems on different drives will
   be checked at the same time to utilize  parallelism  available  in  the
   hardware.   If  the sixth field is not present or zero, a value of zero
   is returned and fsck will assume that the filesystem does not  need  to
   be checked.

The fields in fstab are (if you do a nano /etc/fstab ):

      Field 1        Field 2     Field 3  Field 4       Field 5   Field 6 
   <file system> <mount point>   <type>  <options>       <dump>  <pass>
share|improve this answer
    
+1 - Yes this is perfectly normal behaviour. It's just making sure everything's OK with the file system. If it becomes an issue for you (e.g. you reboot very often) you can change it from the default 30 reboots to, say, 100 by doing: sudo tune2fs -c 100 /dev/sda1. If you want to check how many reboots since last auto fsck do: sudo dumpe2fs -h /dev/sdb1 | grep -i 'mount count'. Let's say you have a big important presentation to give. You don't want a very slow fsck to get in your way. So it can be useful to check. –  boehj May 1 '11 at 15:11
    
But this thing is happening every login. and I always cancenled the process. Actually what I have to do after this check? and Is there any option to allow this process after paricular no of login? –  Silambarasan May 6 '11 at 12:45
    
Are you letting it finish the check process? –  Luis May 6 '11 at 13:26
    
I got following msg when I tried to reset disk checking: silambarasan@silambarasan-PC:~$ sudo tune2fs -c 20 /dev/sda1 tune2fs 1.41.14 (22-Dec-2010) tune2fs: Bad magic number in super-block while trying to open /dev/sda1 Couldn't find valid filesystem superblock. silambarasan@silambarasan-PC:~$ –  Silambarasan Jun 22 '11 at 3:47

I solved my problem, which was the same as Silambarasan's: A few days ago, out of the blue, it started happening that every time I booted up Ubuntu I got "Your disk drives are being checked for errors, this may take some time"--which it did, at least 10 minutes. Very annoying. Finally I noticed that every time I did a shutdown, just before the machine turned off, the following messages repeated briefly across the screen: "could not write" "broken pipe".

So that was why it was checking at every bootup: it was having a problem at every shutdown. I googled broken pipe, and someone advised fixing it by doing "sudo apt-get -f install", which would tell me of an error in /var/lib/dpkg/status. I did that command, but it didn't mention any error. It said:

0 upgraded, 0 newly installed, 0 to remove and 569 not upgraded.

I hadn't allowed any updates since installing Ubuntu. All was working fine, so why upset the apple cart? But now it seemed like that might be the problem, so I did the updates. I'm on Ubuntu 10.04, so did as follows:

  • System > Administration > Update Manager
  • Click the Check button to make sure the package info is as up-to-date as possible.
  • Click the Install Updates button.

And voila! I no longer get "Your disk drives are being checked..." when I bring up Ubuntu. Susan Anderson 12-8-12

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.