Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm hosting on a wampserver running in windows XP as guest in vbox, host is ubuntu 12.04. & I'd like to access my site from outer network, I've double checked all configuration & I believe it to be right, however still encounter an error.

here's a setup:

  1. vbox on ubuntu 12.04 as host
  2. wampserver on win-xp as guest
  3. D-link router port forwarding to 192.168.1.3 && 192.168.1.4
  4. under ubuntu host file I have: 192.168.1.3 domain-on-winXP.com && 192.168.1.4 domain-on2-winXP.com
  5. under win-XP host file I've configured the vhost-doamin-names to localhost
  6. I've configured win-xp for a bridged network.

I can browse domain-on-winXP.com on win-XP && ubuntu on a browser, but when I try to access it from outside network via a online-proxy sites I get a page not found or page can't load error. I'm using DNS service from dnsexit.com & installed the client on WIN-XP to update my IP.

I simply cannot understand what's the glitch?

ifconfig output

eth0      Link encap:Ethernet  HWaddr bc:5f:f4:67:f4:86  
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::be5f:f4ff:fe67:f486/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8200 (8.2 KB)  TX bytes:8460 (8.4 KB)
          Interrupt:47 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:958 errors:0 dropped:0 overruns:0 frame:0
          TX packets:958 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:60668 (60.6 KB)  TX bytes:60668 (60.6 KB)

vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
          inet addr:192.168.56.1  Bcast:192.168.56.255  Mask:255.255.255.0
          inet6 addr: fe80::800:27ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:9644 (9.6 KB)

ipconfig from winXP guest

Windows IP Configuration

        Host Name . . . . . . . . . . . . : algby-21c8b4d99
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : Home

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : Home
        Description . . . . . . . . . . . : AMD PCNET Family PCI Ethernet Adapter
        Physical Address. . . . . . . . . : 08-00-27-E1-BE-06
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.4
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 192.168.1.1
                                            192.168.1.1
        Lease Obtained. . . . . . . . . . : Monday, December 09, 2013 12:36:15 AM
        Lease Expires . . . . . . . . . . : Tuesday, December 10, 2013 12:36:15 AM
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.