Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have made my Transcend USB 3.0 pendrive into bootable ARCH-LINUX key using dd command. After that it become read only and I was not able to use it. So I formatted as MBR with NTFS partition using Disk Utility in Ubuntu and there were no errors, but when I try to use it, it saying read-only and not allowing to copy anything.Here is the screenshot of the error. USB Error

I had tried reformatting as GPT,the same error. I have tried EXT4 also.I have ran fsck command also, it says everything is clear. The following is the output of dmesg | tail -n25

[ 5399.004036] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:2c:41:38:db:7e:b7:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 
[ 5413.351497] type=1400 audit(1386569943.739:66): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=8956 comm="cupsd" pid=8956 comm="cupsd" capability=36  capname="block_suspend"
[ 5438.323077] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:2c:41:38:c8:82:00:08:00 SRC=169.144.44.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=31744 PROTO=2 
[ 5463.333598] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:2c:41:38:db:7e:b9:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 
[ 5472.271930] usb 2-1.5: USB disconnect, device number 3
[ 5479.546220] usb 2-1.5: new high-speed USB device number 4 using ehci_hcd
[ 5479.639030] usb 2-1.5: New USB device found, idVendor=8564, idProduct=1000
[ 5479.639039] usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5479.639044] usb 2-1.5: Product: Mass Storage Device
[ 5479.639047] usb 2-1.5: Manufacturer: JetFlash
[ 5479.639052] usb 2-1.5: SerialNumber: 1250498862
[ 5479.639699] scsi17 : usb-storage 2-1.5:1.0
[ 5480.636704] scsi 17:0:0:0: Direct-Access     JetFlash Transcend 8GB    1.00 PQ: 0 ANSI: 6
[ 5480.637548] sd 17:0:0:0: Attached scsi generic sg2 type 0
[ 5480.638034] sd 17:0:0:0: [sdb] 15433728 512-byte logical blocks: (7.90 GB/7.35 GiB)
[ 5480.638406] sd 17:0:0:0: [sdb] Write Protect is off
[ 5480.638415] sd 17:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 5480.638771] sd 17:0:0:0: [sdb] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[ 5480.650924]  sdb: sdb1
[ 5480.652992] sd 17:0:0:0: [sdb] Attached SCSI removable disk
[ 5480.798379] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[ 5486.400055] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:2c:41:38:db:7e:ae:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 
[ 5486.826155] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:2c:41:38:db:7e:af:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 
[ 5487.220538] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:2c:41:38:db:7e:ba:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 
[ 5514.209561] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6

Update: This is weird, I have formatted as FAT, I have checked the permissions, it is normal (-rw-r--r--). I have opened Terminal and used mkdir and a directory is created. I am able to create files also from cmdline, but whenever I try to access through nautilus , the error mentioned at the start is occuring. I have checked in my friend's laptop, there is no problem. Still can't understand the problem.

share|improve this question
    
yes! you can recover your pendrive. Try formatting from a VM ware or virtualbox using backtrack or any other OS. if u couldnt format then try changing read only properties for owner and then come back to real window(non virtual), do format. it will work fine. –  user239073 Jan 23 at 17:30

1 Answer 1

up vote 2 down vote accepted

Format the usb drive into fat32 filesystem using gparted partition Editor.After that remove it from the pc,reboot the pc and then reinsert the usb-drive.Now it works.

To give read,write,execute permission to your usb try the below command,

sudo chmod 777 /media/usbpartition-name
share|improve this answer
    
I am on my office laptop,and I don't have root access, I will try that in Personal Laptop. is there any difference , if we partition using Disk utility and Gparted ..? In Windows, I am unable to format it as it is saying USB device not recognized –  saiki4116 Dec 9 '13 at 8:11
    
just a piece of advice, if you can access windows, can you work your way around diskpart.exe in cmd.exe ? –  ASCIIbetical Dec 9 '13 at 10:01
    
In windows, it's not getting recognized, So I was unable to format in windows. I think this is random bug in Nautilus, after a reboot, everything is fine. –  saiki4116 Dec 11 '13 at 6:25
1  
+1 worked out for me! –  Sahil Sareen Mar 16 at 12:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.