Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, before everyone screams duplicate, my scenario is unique because I've exhausted what options I can comprehend and there aren't any clear answers available. I feel it will valuable to have this answer available for beginners who won't want to go through the install process a second time just to have to figure out how to fix this then figure how to encrypt system via command line.

I've done a clean install of ubuntu 13.10 with filesystem encryption... I chose to have updates applied as it was installed, but of course the notorious "keyboard not working at the 'enter passphrase:'" reared it's ugly head.

what can't be done; This is a fresh install to a virgin hard drive (that was another fun bug to figure out btw) so using an older kernel isn't an option. (AFAIK)

what I've tried;

  1. Booted live CD and "try ubuntu".
  2. Mounted encrypted filesystem as to have access to it.
  3. Fired up a terminal (ctrl alt T)
  4. sudo mount --bind /dev /media/ubuntu/*driveid*/dev/
  5. sudo mount --bind /proc /media/ubuntu/*driveid*/proc/
  6. sudo mount --bind /sys /media/ubuntu/*driveid*/sys/
  7. sudo chroot /media/ubuntu/*driveid*
  8. nano /etc/initramfs-tools/modules
  9. Added a host of modules under the comments, one on each line.

    # List of modules that you want to include in your initramfs.
    # They will be loaded at boot time in the order below.
    #
    # Syntax:  module_name [args ...]
    #
    # You must run update-initramfs(8) to effect this change.
    #
    # Examples:
    #
    # raid1
    # sd_mod
    ohci_pci
    hid
    usbhid
    hid_generic
    hid_logitech
    hid_logitech_dj
    mac_hid
    
  10. Ctrl+o to write out
  11. Enter to save the file
  12. Ctrl+x To close nano
  13. update-initramfs -u
  14. Unmount everything (not sure if necessary but I did), restart without ubuntu CD, problem persists...

Edit:

I should also note, that I changed the cryptkey="Unlocking the disk driveid Enter Passphrase:" to "By Your Command:" in media/ubuntu/*driveid*/usr/share/initramfs-tools/scripts/local-top/cryptroot however it still comes up as

Unlocking the disk *driveid*

Enter Passphrase:

on reboot

Keep in mind however I did this AFTER my first attempt to do the above list, so it has nothing to do with why the keyboard wont work even after my attempted fix, but it does lead me to ask if this string hasn't changed then has the update-initramfs -u worked at all or am I still not loading those modules.

Here's the output I get after running update-initramfs -u

    root@ubuntu:/# update-initramfs -u
    update-initramfs: Generating /boot/initrd.img-3.11.0-12-generic
    grep: /boot/config-3.11.0-12-generic: No such file or directory
    cryptsetup: WARNING: invalid line in /etc/crypttab for luks-1ca6df5d-4b58-4c47-a5ec-7e6594305900 - 

Edit 2:

Doing sudo mount --bind /boot /media/ubuntu/*driveid*/boot before chroot-ing got rid of the

    grep: /boot/config-3.11.0-12-generic: No such file or directory

So apperently it was pointing to the wrong /boot (the live cd boot instead of the hard drive) however, this still has not caused "By Your Command:" to appear and the keyboard still does not function

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.