Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My system is using the Ambiance theme in Ubuntu Natty. Everything works correctly except for Nautilus, which appears to have been deprived from its theme. Grey nautilus doesn't look healthy

Can anyone help me restore it to the default Ambiance theme? (I've tried setting other themes but Nautilus is still grey)

If I open Nautilus with 'sudo' from the terminal, this bug isn't present and the theme is shown correctly.

I thought the Desktop forgets theme? answer would solve my problem, but after restarting, the theme-less Nautilus is back.

Something I noticed is that this problem is present in Nautilus and with Nautilus only. As I said, if I run Nautilus as root the problem isn't present, only when running Nautilus as a normal user

share|improve this question
    
I think you probably messed the own of some configurations files. I will search a solution. –  desgua May 1 '11 at 20:54
    
    
I bet after running it with sudo that some of the config files now belong to root and your user account can't access them. –  Jorge Castro May 2 '11 at 19:55
    
Is there any way to reset this Nautilus configuration? I don't mind using the default theme... –  bruno077 May 2 '11 at 19:57
add comment

6 Answers 6

up vote 5 down vote accepted

Well, after searching around. Adding a delay to gnome-settings-daemon when logging in corrected the problem

share|improve this answer
    
This also shows up in the Linux Mint 11 known issues: linuxmint.com/rel_katya.php –  Alin Andrei Jun 3 '11 at 8:43
add comment

Can you change your icons theme?

Instructions:

1) Hit Alt+F2 and paste gnome-appearance-properties

2) Go to "Theme" and click "Customize".

enter image description here

3) Go to "Icons" and choose one.

enter image description here

share|improve this answer
    
I just tried, I can change the icons but nautilus is still theme-less. Please see my update –  bruno077 May 1 '11 at 19:56
add comment

change the theme as root and put the themes you want in root.. this works for me..

in otherwords become root and bring up your customization and select your theme or just download ubuntu tweak and have it fix the root theme bug

share|improve this answer
add comment

There's definitely some kind of configuration issue going on. Currently it seems like root and your login have different settings for themes.

Try running gksu gnome-appearance-properties

If you already see your default theme in there, and it isn't selected, all you need to do is select it.

if you don't see your theme in there, it will explain why root defaults to another theme. Then you should check if your default theme is install at /usr/share/themes/ or simply install them again to that location.

if it's there and it's already selected, or selecting it doesn't make a difference, then still check your /usr/share/themes/ folder to see if the files are missing or broken or have wrong permissions.... hope this helps.

share|improve this answer
add comment

yeah that fixed it for me

mv ~/.gconf/apps/nautilus ~/.gconf/apps/nautilus.old && killall nautilus

..if it helps the last time I remember it was ok was the day before I 'discovered' dconf, so assume I broke it with that - or it was a coincidence.

share|improve this answer
add comment

I found great solution here:

rm -vr ~/.gconf/apps/nautilus && killall nautilus
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.