Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's been an issue for quite some time to set the number of different desktops (or workspaces if you like) in the new Ubuntu Natty Narwhal (using unity).

Some guys figured out a way to overcome it by using the compiz-config(CCSM). For some reason it seems that the CCSM doesn't really work for me. I change the number of desktops, and the expo but it won't work.

share|improve this question
    
Did you change the horizontal and vertical –  Rinzwind May 2 '11 at 18:26
    
Does expo not work or does it just still have 4 workspaces? –  pydave May 4 '11 at 0:09
add comment

migrated from stackoverflow.com May 1 '11 at 13:03

This question came from our site for professional and enthusiast programmers.

5 Answers

up vote 4 down vote accepted

I don't see why ccsm wouldn't work, but if you really want to do it on the command line, you can directly access gconf.

Open Terminal and try these commands.

Running this in a terminal will tell you your current setting:

gconftool --get /apps/compiz-1/general/screen0/options/hsize

Running this will change your horizontal and vertical size to 3:

gconftool --set /apps/compiz-1/general/screen0/options/hsize --type=int 3
gconftool --set /apps/compiz-1/general/screen0/options/vsize --type=int 3

If you have multiple screens or other complications, then this might not work.

share|improve this answer
2  
And if you're looking for things like this in the future, you can open gconf-editor (called Configuration Editor in the menu) and search for relevant keywords. Ignore anything under /schemas/ –  pydave May 4 '11 at 0:29
add comment

If you still can not use CCSM you could also add an indicator. See the image:

image1

Add ppa:geod/ppa-geod to your Software Sources, update and then search for indicator workspaces or do a sudo apt-get install indicator-workspaces

References:

share|improve this answer
add comment

Did you change the horizontal and vertical size? These change the number of workspaces. I would have expected it to be 'number of desktops' but it is the other 2 you need to change ;-)

Desktop Size in general options

Like the image shows mine is 3 by 2.

share|improve this answer
    
Tried that already. (my mistake for writing "number of desktops") –  Royi Freifeld May 3 '11 at 20:20
    
Woah. Why is your Number of desktops set to 4? Does that do anything? –  pydave May 4 '11 at 0:13
    
It shows a 3x3 desktops. But when I change between one desktop to another (via a ctrl+arrow_key) , I see only 6 available in a row. and when I use the "change desktop" button the new Unity bar, there's place for 9 windows filled by only 6. gconftool --get /apps/compiz-1/general/screen0/options/hsize gconftool --get /apps/compiz-1/general/screen0/options/vsize both return 3. It's kinda weird. –  Royi Freifeld May 6 '11 at 10:25
    
I don't know if it has something to do with anything, but when I check the /apps/... path in gconf-editor It says "This key has no schema". –  Royi Freifeld May 6 '11 at 10:44
1  
@pydave: no does not seem to work. That one is for having multiple desktops on 1 viewport (you could have 8 or 12 viewports with 2 or 3 cubes each holding 4 sets of workspaces). I wanted to see if this works again but this got removed in hardy and never came back (due to too many problems) –  Rinzwind May 7 '11 at 20:06
show 1 more comment

a round-about way, but easy enough is the following:

open a terminal and type in

gnome-panel

the top and bottom original gnome menu bars appear and on the bottom one you will see the workspaces icon which you can then right-click and properties in the usual manner.

close the terminal and if the menu bars remain, just right click them each individually and remove them... click on your workspace icon in the unity side-menu and you will now see the amount of desktops you set.

share|improve this answer
    
The best answer do far. I do not like those "advanced-user" answers. –  Willian Girhad May 7 '11 at 20:32
    
thanx... i usually fiddle till i find a way, and along the way I exhaust all options... –  george May 10 '11 at 11:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.