Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I remove the Workspace Switcher launcher from the Unity dock?

share|improve this question

7 Answers 7

For Ubuntu 11.04/11.10/12.04 (does not work in Unity 2D):

  1. Install Compiz Config Settings Manager Install compizconfig-settings-manager from the Ubuntu Software Center

  2. Open Compiz Config Settings Manager from Dash

  3. Goto General Options and Desktop Size tab

  4. Change Horizontal Virtual Size to '1', the Vertical Virtual Size can be any number.

  5. Restart Unity by opening Run Command (Alt-F2) and typing unity

compizconfig

Source

share|improve this answer

For 14.04

Drag the undesirable icon on the trash can.

For 13.04

By default, the workspace-switcher is not enabled in the Launcher. This setting is toggleable via the Appearance - Behaviour tab in System Settings

Untick the option shown in the following picture to remove the workspace-switcher icon.

enter image description here

12.10

If you are prepared to work with just one virtual desktop (i.e. no additional workspaces) then the following will work for 12.10 and later.

gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ hsize 1
gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ vsize 1

Before:

enter image description here

After:

enter image description here

share|improve this answer
2  
this actually worked for me on 12.10 and seems a crap load easier than the top answer –  nyne Jan 11 '13 at 13:50
4  
Your solution for 13.04 isn't exactly a solution. Disabling workspaces will completely disable them, not just remove the icon from the launcher. Some people are going to want to leave workspaces enabled without the icon in the launcher. –  Seth Sep 17 '13 at 19:14
    
Agree with @Seth - if you untick the "Enable workspaces" option it seems to reset your workspace preferences (for example the number of panels you have horizontally and vertically). I'm just looking to remove the icon, since Hotcorners is enough for me. –  halfer Apr 4 at 7:03
1  
12.10 solution gives: No such schema 'org.compiz.core' –  Bryce Sep 4 at 6:21
    
@Bryce the same here, how did you solve it? –  Pablo Matías Gomez Oct 29 at 15:56

12.04

Install MyUnity from Software Center.

Open it, go to Desktop, decrease (move the bar to the left) for H Desktop and V Desktop, both to minimal.

Restart.

share|improve this answer
  1. To disable workspaces completely
  2. To just remove the icon but still preserve workspaces

    • Open the terminal and execute:

      gsettings get com.canonical.Unity.Launcher favorites
      

    the output will be something like,

    ['application://nautilus.desktop', 'application://chromium-browser.desktop', 'application://ubuntu-software-center.desktop', 'application://ubuntuone-installer.desktop', 'application://ubuntu-amazon-default.desktop', 'application://UbuntuOneMusiconeubuntucom.desktop', 'application://gnome-control-center.desktop', 'unity://running-apps', 'unity://expo-icon', 'unity://devices']`
    

    To remove the workspaces icon from the dock you should just take out 'unity://expo-icon' from that list. Taking it out, for this case the command should be:

    gsettings set com.canonical.Unity.Launcher favorites "['application://nautilus.desktop', 'application://chromium-browser.desktop', 'application://ubuntu-software-center.desktop', 'application://ubuntuone-installer.desktop', 'application://ubuntu-amazon-default.desktop', 'application://UbuntuOneMusiconeubuntucom.desktop', 'application://gnome-control-center.desktop', 'unity://running-apps', 'unity://devices']"`.
    

    (Don't forget the double quotes for the list on gsettings set)

Currently I'm using eight workspaces with the help of Unity Tweak Tool. I like to have multiple workspaces, but didn't like the unremovable Unity Launcher icon that much, even more because it could only resemble four workspaces while I was using eight instead.

share|improve this answer
    
Did the job. Thanks! –  chzbrgla Jun 26 '13 at 8:10
3  
This did exactly what I wanted to do. The other answers disable the desktop-switching completely, while this answer only removes the icon and I'm still able to use the feature itself. –  Donarsson Sep 7 '13 at 11:12
    
For what versions should this be working? –  Bruno Pereira Sep 7 '13 at 17:44
    
@BrunoPereira, personally, I could only use it on 13.04. –  pepper_chico Sep 7 '13 at 18:12
1  
This is the most logical, straight-forward approach, and it works! (using Ubuntu 14.04) –  dayuloli May 31 at 1:49

12.04

This is now easy, thanks to an addition to Isaac Joseph's lovely Unity Revamped (also brings back dodge-windows and dodge-active-window and gives a few other options).

Add the repository with your software manager of choice or:

sudo add-apt-repository ppa:ikarosdev/unity-revamped

This is now an alternative source of unity, that'll report itself as just slightly ahead of the canonical one in version. Upgrade and you'll have this new version:

apt-fast update && apt-fast dist-upgrade

Or if you don't use apt-fast, then:

sudo apt-get update && sudo apt-get dist-upgrade

Or just use the software updater.

Log out and in, and go to ccsm. The Ubuntu Unity Plugin will now have, on the "experimental" tab an option labelled 'Show "Expo Icon" in the launcher', that's enabled by default. Disable this and the icon is gone.

Disabling the icon doesn't disable the Super+S binding, should that be your preferred way of switching workspaces.

share|improve this answer

For Ubuntu 11.10 & Ubuntu2D

Edit the file /usr/share/unity-2d/launcher/Launcher.qml with your favorite text editor, ie:

sudo nano /usr/share/unity-2d/launcher/Launcher.qml

For Ubuntu 12.04 & Ubuntu2D

Edit the file /usr/share/unity-2d/shell/launcher/Launcher.qml with your favorite text editor, ie:

sudo nano /usr/share/unity-2d/shell/launcher/Launcher.qml

Locate these lines

    Component.onCompleted: {
        items.appendModel(bfbModel);
        items.appendModel(applications);
        items.appendModel(workspaces);
        items.appendModel(devices);
        shelfItems.appendModel(trashes);
    }

And change them to

    Component.onCompleted: {
        items.appendModel(bfbModel);
        items.appendModel(applications);
/*        items.appendModel(workspaces);*/
        items.appendModel(devices);
        shelfItems.appendModel(trashes);
    }

Ubuntu

Unfortunately the desktop switcher is hard coded to unity and cannot be removed without making source code modifications.

Make sure you have the package dpkg-dev installed

sudo apt-get install dpkg-dev

To modify the code and compile it your self you need to do the following

mkdir ~/code
cd ~/code
mkdir build
cd build
apt-get source unity
cd unity*

Open plugins/unityshell/src/LauncherController.cpp with your favorite text editor, ie:

nano plugins/unityshell/src/LauncherController.cpp

Locate the lines

num_workspaces_ = WindowManager::Default()->WorkspaceCount();
if (num_workspaces_ > 1)
{
  InsertExpoAction();
}

Change them to

/*num_workspaces_ = WindowManager::Default()->WorkspaceCount();
if (num_workspaces_ > 1)
{
  InsertExpoAction();
}*/

Build the package

sudo apt-get build-dep unity
debuild -us -uc

Wait for it to finish and install when done

cd ..
sudo dpkg -i unity*.deb libunity*.deb netbook*.deb
share|improve this answer
1  
Do not use the method with Unity 2D 12.04. Afterwars you cant even start unity. I had to go into another desktop-enviroment and revert the changes. –  wegsehen Jun 2 '12 at 18:57
    
sorry but, for Unity, I should warn people are better of checking the other answers. –  pepper_chico Apr 27 '13 at 14:15
1  
For what versions? What is the problem with this solutions? –  Bruno Pereira Apr 27 '13 at 19:45
    
@BrunoPereira, check my answer for example, I suspect the gsettings trick work in several versions. No need for compiling stuff, and also, that's an issue with your answer because you assert there's no other way out but patching. –  pepper_chico May 3 '13 at 16:56
    
Thanks for the solution! Other people here say it breaks Unity2D. Just make sure you did it right. The first time I tried, I broke Unity2D too because I addicently swapped the last * and /. After fixing it, it worked. (12.04) –  Jop Vernooij Sep 12 '13 at 15:02

11.04

Currently there's a handy little bug in unity that allows you to do this. Open a up a terminal and run 'gnome-panel'. Once gnome panel is running, add the 'workspace switcher' applet to the panel. Open up the workspace switcher preferences and select 1 column and 4 rows. Log out and back into unity, and viola! The workspace switcher is missing now.

Yes I know, it's a somewhat annoying way of removing it if you use workspaces, but it's the only way i know of right now..

enter image description here

To get the Unity launcher switcher back, simply open the gnome-panel in terminal again, and go back to a 2 X 2 grid. Logout and log back in.

share|improve this answer

protected by jrg Apr 27 '13 at 2:28

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.