Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since karmic koala, I can't create a bootable USB. Always the same error, it arrives to 96% and then this error " checksums do not match". Also in lucid, meerkat and natty even with fresh install. Tried it with more than USB stick.

Am I doing somthing wrong? I did format the USB stick several times but no luck. It's 2Gb. Now I lost my DVD drive on my laptop, and USB is my only option. Please help!

  1. I did try different USB sticks
  2. I did try unetbootin, with success, but when booting from USB and selecting check disk for errors within the unetbootin menu it gives me 1 error, so I didn't try actually to install the O. S for precaution reasons.
  3. I did try to launch disk creator from terminal with sudo and that gives the same error on 96% of the process.

  4. doing the check proposed by chen xiao-long, the codes result no match.

    suliman@suliman-laptop:~$ sudo mount -o loop /home/suliman/Documents/ubuntu-11.04-desktop-i386.iso /mnt

.

[sudo] password for suliman: 
suliman@suliman-laptop:~$ md5sum /mnt/casper/filesystem.squashfs
174bb50daab963e681d2dcd9603f737b  /mnt/casper/filesystem.squashfs
suliman@suliman-laptop:~$ md5sum '/media/8BE1-C58A/casper/filesystem.squashfs' 
e4129f8ff21860d978c911b3b394f807  /media/8BE1-C58A/casper/filesystem.squashfs

EDIT 2 5. if the usb port is faulty, how can i check that?

share|improve this question

6 Answers 6

up vote 1 down vote accepted

problem solved, but no answer to the question. i used unetbootin with success but the problem with ubuntu disk creator remains.

share|improve this answer
    
did you try another storage device? –  dsaint May 27 '11 at 15:33
    
yes , i did try. –  suli8 May 27 '11 at 15:38

I removed the usb-creator-gtk, rebooted, reinstalled it, deleted the partition on the usb drive using disk utility, created new partition and attempted using usb-creator-gtk again with success. Not sure which of the steps above actually resolved the problem.

share|improve this answer

Using a Kingston 4GB Data Traveler USB stick I was getting the same checksum error.

Then as Jordon Bedwell (above) suggested I dropped the persistence file from 1GB down to 256MB and it went through without a hitch; or the checksum error popping up.

Used USB Startup Disk Creator from the menu. Using Ubuntu 10.04 LTS to make a 11.04 USB.

Thanks Jordon

share|improve this answer

The installer iso file might be corrupted. Therefore, you should check the .iso file with md5sum before creating a bootable usb.

Check the iso file:

md5sum ubuntu_iso_file.iso

Then compare the output with the original ones in the official site.

share|improve this answer
    
i did that on the last one 11.04. it was ok, they match. and it did happened with every iso i downloaded. –  suli8 May 1 '11 at 15:16
    
i did. nothing helps. i don't know what else to do –  suli8 May 4 '11 at 11:38
    
did you try with a different usb stick? –  Coldfish May 4 '11 at 13:25
    
yes. it is in the question itself. i tried 3 differnet ones. –  suli8 May 20 '11 at 22:44
    
did you use start up disk creator or unetbootin? unetboot in is available in synaptics and worked better for me. –  dago May 20 '11 at 23:09

I'd suggest using Unetbootin. When the CD is copied to your USB drive, the syslinux bootloader has to be installed to it, rather than isolinux from the CD. The different files on the USB drive compared to the CD probably caused the problem when you selected the disk checking option.

The main thing to check is that the md5sum of the /casper/filesystem.squashfs file on your USB drive is the same as that file on the ISO. All the other files are just "helper" files that allow the USB drive to boot. They aren't used during or after the install.

To check that the md5sums are the same, you can run

sudo mount -o loop /path/to/ubuntu.iso /mnt
md5sum /mnt/casper/filesystem.squashfs
md5sum /path/to/USB/casper/filesystem.squashfs

and then make sure that the outputs are the same.

share|improve this answer
    
now , using this method the md5sums does not match. –  suli8 May 22 '11 at 10:19
    
That's very strange. I've had a similar problem before, but that was on an old computer with a failed USB port. Since you've tried multiple USB sticks, there's probably something wrong with the computer itself. –  Xiao-Long Chen May 22 '11 at 12:47
    
i have 4 usb ports, and all working as recognizing devices and data transfer. how can i be sure that it is the usb that is faulty? –  suli8 May 22 '11 at 18:25
    
I'm not sure how to check if the USB ports are faulty. Maybe someone else can help here? I can't think of any other reason why the checksums would be different... –  Xiao-Long Chen May 22 '11 at 18:49
    
thanks for the help! –  suli8 May 22 '11 at 20:47

Disable the reserved storage or make it under 500MB.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.