Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With the following method I was able to brick 2 different Surface Pros with the exact same methods.

  1. you shrink your partition on Windows and disable those 2 secure-boot/uefi settings from the advanced startup screen.
  2. boot from a usb stick and install Ubuntu as you should (wireless not working as reported).
  3. after the installation completes, reboot (by holding the power down because it hangs while restarting)
  4. grub loads as usual, ubuntu login screen appears. but once you hit your keyboard a few times for your password entry it hangs.
  5. so once again hold power down to shutdown, and then reboot again.
  6. BANG! As soon as the Surface Pro starts, it now reports low battery warning and shuts itself. Battery is full btw. No matter you plug in the charger, the machine is stuck, it always reports the battery low and you're stuck.

That's how I bricked two Surface Pro's in two days. Any help regarding a recovery operation would be great.

share|improve this question

closed as off-topic by karel, Braiam, Mateo, blade19899, Alvar Dec 16 '13 at 13:31

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Mateo, blade19899, Alvar
  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – karel, Braiam
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

The link below might help you get it back up and working again. Good luck.

http://thingsthatmightinterestnerds.com/surfacepro_dumpfactoryimage/

share|improve this answer
    
thanks but that would not work because the machine is stuck at the boot up process, before any OS is even attempted to load. –  user223271 Dec 8 '13 at 2:07
up vote 0 down vote accepted

Just before i was about to return the machines i wanted to try once more (after 24 hours). To my suprise both machines did boot up this time. There's definitely some sort of bug in some of that uefi code that queries the battery status.

Anyway, i'm glad the machines are back and I think I won't be trying to install Ubuntu natively in a foreseeble time.

Latest update for the record: I couldn't resist and tried to install Ubuntu again a month later. I went with 14.04 daily image and opted for using the entire disk (wiped Windows, no dual-boot), and this time it worked.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.