Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Edit FOUND MY ANSWER BY USER 'SALEM'.

Turns out to be numlock on my laptop ( didn't think I had one since I don't have a NumPad..)

Where I found the answer: Restore keyboard character mapping


I used the Razr Lycossa keyboard for a couple of days and when I UNPLUG the Lycossa keyboard and try to use my laptop's native keyboard the keys are scrambled.

The scrambling is in the - j, k, l, u, i, o keys which become 1, 2 ,3 ,4 ,5 ,6 respectively. I run ubuntu 12.04 LTS.

THIS ONLY happens when Lycossa keyboard isn't plugged in. If I plug it back in the Lycossa keyboard inputs fine and correctly.

Is the Lycossa overriding my settings or something?

I have tried:

sudo dpkg-reconfigure console-data

and

sudo dpkg-reconfigure keyboard-configuration

and adjusting keyboard layout ( says English in menu and when I preview it looks fine ) and the language ( also English ).

Any ideas? I would like to use my laptop's keyboard only without the external but cannot since I lost function on my JKLUIO keys.

Also, on screen keyboard works fine and I have to use it to login if I don't have the Lycossa to plug in..

Thanks

share|improve this question
    
It sounds like num-lock is turned on. –  Paul-92711864 Dec 8 '13 at 0:43
    
Yep.. you are 2 minutes too late :P but thanks man! :) –  user223252 Dec 8 '13 at 0:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.