Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

You all know the nice default font that come with Ubuntu, right? I just wanted to play a little bit with Kubuntu and installed the meta package

kubuntu-desktop

Everything was fine, however the font is now ugly as hell. Not only on KDE, but also on Gnome, Unity etc.

Example: enter image description here

How can I get the default font config back?

share|improve this question
    
Look also at askubuntu.com/questions/159085/… –  warvariuc Oct 17 '13 at 15:03

2 Answers 2

In your home folder, rename .fonts.conf to .fonts.conf.bak then log out. Log back in and the fonts in Firefox are good to go.

share|improve this answer

Looks like you have to to disable font hinting, either through GNOME/KDE settings or by putting the following in ~/.fonts.conf (create the file if it doesn't exist):

<match target="font">
  <edit name="hinting" mode="assign">
    <bool>false</bool>
  </edit>
</match>

This is configurable because some people prefer crispier look reminiscent of Windows XP.

share|improve this answer
    
I confirm that this solved the problem. –  sorin May 3 '12 at 12:17
    
This is also working for me, please select it as the answer. –  Misha Rogalla Mar 10 '13 at 19:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.