Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing MatLab on Ubuntu 12.04 from an .iso, unsuccessfully. The .iso file is mounted, but when I go to the mounted folder and type ./install , I get this error message:

Error: Cannot locate Java Runtime Environment (JRE).
The directory /mnt/iso/sys/java/jre/glnx86/jre does not exist.

That seems pretty normal, since the directory glnx86 doesn't exist, but instead, in the install script, it seems like this should be exchanged with glnxa64, which does exist. I tried to modify the script in the install file and deleted the glnx86 values, retried to run the script, but then I get another error message:

Preparing installation files ...
Installing ...
/tmp/mathworks_11559/sys/java/jre/glnxa64/jre/bin/java: 1: /tmp/mathworks_11559/sys/java/jre/glnxa64/jre/bin/java: Syntax error: "(" unexpected
Finished

Can someone help me out of this, please?

share|improve this question
1  
    
I checked that, but I think that it won't help. Apparently this is a fix for the 64 bit version, but I'm running a 32 bit version. Thus, trying to get the "ia32-libs" package won't work. But I think I see the problem here: I have a version of Matlab made to run in only 64 Ubuntu (2012b, 2012a seems to be the last version for 32 bit). Should I mark this solved? –  user223087 Dec 7 '13 at 17:09
    
If you got it solved then feel free to close it. But please add additional information regarding how you came to that conclusion. –  Bhathiya-JaDogg-Perera Dec 8 '13 at 12:59

1 Answer 1

up vote 0 down vote accepted

The last version of MatLab supported by a 32-bit Linux OS is the 2012a. All versions coming after this one can only be installed on a 64-bit Linux OS. I upgraded my OS to Ubuntu 12.04 64-bit, and installed the 2013a version of MatLab following the instructions that already exist in the forum. By the way, it looks that the fix for "ia32-libs" (mentioned as comment on my previous question) is only needed for older versions of MatLab, in my case there was no need to get the package.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.