Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm using a Lenovo SL500 for several years now and suddenly the Volume keys stopped working. It could be that a kernel updated caused it - I don't know.

However when I go to the keyboard settings -> Shortcuts -> Sound and Media, I can set e.g. Volume Mute with my multimedia key and then it says "AudioMute". But when I later hit the Volume Mute key nothing happens.

share|improve this question
    
Maybe your volume/mute keys got reassigned to some other program? –  Pavel Dec 7 '13 at 10:33
    
How can I check this? –  tauran Dec 8 '13 at 15:36
    
askubuntu.com/questions/24916/how-do-i-remap-certain-keys –  Pavel Dec 8 '13 at 16:05
2  
It's a bug, see here................ bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… –  user302077 Jul 9 '14 at 23:01
1  
There is another one here too.. bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/… –  Guilherme Sep 13 '14 at 17:25

3 Answers 3

up vote 5 down vote accepted

I found a solution: deleting ~/.pulse then logout. Next time it happens I will try the other answer too.

share|improve this answer
2  
This has fixed my problem, but you must reboot the computer, not just logout, or you may find all the sound controls to be quite broken. I recommending taking a backup of .pulse incase you need to revert. –  Steve May 30 '14 at 8:40
    
This is the right answer, helped me too. –  Piotr Jurkiewicz Sep 20 '14 at 0:40
    
Deleted folder and rebooted. This helped in my case as well (Asus N55S). It restored the sound previously gone from the left headphone channel and the volume and mute keys. Thanks! –  Andrea Borga Dec 2 '14 at 22:03
    
I just killed pulse-audio instead of logging out, it worked –  vanjoe May 5 at 20:33

Resetting media key prefrences worked for me

dconf reset -f /org/gnome/settings- daemon/plugins/media-keys/

if it does not work maybe you should try

dconf reset -f /org/gnome/settings- daemon/plugins
share|improve this answer

I had the same issue on 15.04

There was no .pulse but there was .pulse-cookie. So I deleted it and it works like a charm now.

So updated solution for 15.04:

sudo rm ~/.pulse-cookie
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.