Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

whit 10.10 I did't had this problem I was able to run programs from my windows Drive through Wine by just double-clicking or selecting run by Wine, but in 11.04 when I run program this way it says :

The file '/media/Drive/Software/Games/Borderlands/Gearbox Software/Borderlands/Binaries/Borderlands.exe' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.

and I try changing permissions of file to be executable but it keeps changing back every time i change it

I read that it's blocked because of windows viruses but i'm sure that this files are safe and I can run them safely but now how can I change it. Thanks.

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

If you can not manage to chmod the .exe to be executable, you can always fall back to using the command line to run the .exe. ie:

wine /media/Drive/Softwaretorun.exe or if theres spaces in the path.

wine "/media/Drive/Soft Ware.exe"

The whole '.exe' must be executable - is a nice way to put another layer of security on things, but when the .exe is on a filesystem that you can not make the .exe executable (such as on an ISO, or remote share, or ntfs/vfat mounted with options where its not the default) it can cause problems.

The Command line way of running a .exe should always work.

Just for extra clarification, you can not change the modes or permissions of files on a NTFS/Vfat once they are mounted. You must mount them with the proper options, then the options normally set ALL files on the ntfs/vfat to be executable, this is often a bigger annoyance then the wine not working annoyance.

share|improve this answer
add comment

install ntfs-config

then tick the "Enable write support for internal devices" chekbox

if your windows drive not mounted automatically, type in terminal

sudo mountall

or reboot

share|improve this answer
add comment

You could always do this from the command line.

chmod +x /media/Drive/Software/Games/Borderlands/Gearbox Software/Borderlands/Binaries/Borderlands.exe

...and if Linux refuses to make you a sandwich add the permission:

sudo chmod +x /media/Drive/Software/Games/Borderlands/Gearbox Software/Borderlands/Binaries/Borderlands.exe
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.