Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Under Ubuntu 10.04 one of the problems which appeared is that USB devices would no longer automatically mount when plugged in. Normally I would get a pop up message asking what application I wanted to open the newly plugged in device with, however now that doesn't happen.

This happens regardless of the way the device is formatted (NTFS or FAT32) and all other USB devices (printer, keyboard and mouse) work perfectly.

My current solution is the mount them manually using sudo mount dev/... /medai/... however to be honest I'm just getting tired of having to do this.

I'm happy to post any extra information you are likely to need. I know there will be lots of places I could look to find out what's going wrong but I have no idea where to start really.

share|improve this question
    
I'd start by looking whether there are log entries in ~/.xsession-errors, /var/log/daemon or /var/log/kern when you attach a device... –  poolie Sep 9 '10 at 0:38
    
@poolie Nothing obvious. Lots of "no route to host"'s in the xsessions one though –  matto1990 Sep 9 '10 at 9:23
    
Does it also happen when you boot from a live-cd or live-usb? It's the whole 'i upgraded to' statement, that makes it quite hard to figure this out. Was it a fresh install? Or was a customized ubuntu, perhaps with a bunch of PPA's, that you were upgrading? –  Ralf Sep 11 '10 at 12:38
    
@Ralf Sorry, it was actually a fresh install. I forgot I tried to just do the update but it broke and ended up just doing a fresh install. I'll update the question to reflect this. –  matto1990 Sep 12 '10 at 19:58
add comment

9 Answers

Try in Nautilus → Edit → Preferences → Media

share|improve this answer
    
All of them are set to "ask what to do". That's ok I'm guessing. –  matto1990 Sep 8 '10 at 23:01
add comment

This happened to me in xubuntu. It used to mount automatically but now it does not. My workaround was I installed an extra package called usbmount.

sudo apt-get install usbmount

share|improve this answer
    
I've installed it but when I plug in a device noting ever gets mounted in any of the usb<X> folders. –  matto1990 Sep 9 '10 at 9:54
    
This seems to be a regular problem: ubuntuforums.org/showthread.php?t=1468755 and ubuntuforums.org/showthread.php?t=1470705 and I found one script which automatically mount ntfs formats: webupd8.org/2010/04/ubuntu-script-to-automatically-mount.html. –  sagarchalise Sep 11 '10 at 4:07
add comment

In gconf-editor, look under /apps/nautilus/preferences. There should be a setting called "media_automount". Ensure that it is checked. There is also an option called "media_automount_open" that you can set if you wish it to open the media in nautilus automatically in addition to mounting it.

share|improve this answer
    
Both are check already and the problem still persists –  matto1990 Sep 12 '10 at 19:57
    
Damn ... I was confident –  Nerdfest Sep 12 '10 at 23:52
add comment

If you run (Alt+F2) "ubuntu-bug storage", your problem is the very first option. It may not be a bug, but a bug report would be the easiest way to rule that out.

Oh and please post a link to the bug report here if you do.

share|improve this answer
    
I've done that and launchpad suggests that this bug is the same and I don't need to post another one. It seems to be marked as fixed though :S bugs.launchpad.net/ubuntu/+source/gvfs/+bug/435136 –  matto1990 Sep 12 '10 at 20:01
add comment

It is a known issue with 10.04 if you have a floppy drive. Here is a solution:

  1. Open a terminal (Ctrl+Alt+F2).
  2. Type: gksu gedit /etc/fstab
  3. Add a # before the line that contains fd0.
  4. Then in terminal type: rmmod floppy
share|improve this answer
    
I'm on a laptop with no floppy drive and there's no line like that in my fstab. Do I need lines in fstab to point to the removable devices or is this not what fstab is for? –  matto1990 Sep 12 '10 at 20:06
    
No. Removable devices don't need a line in fstab. Just the filesystems that are mounted at boot need them. –  Javier Rivera Sep 14 '10 at 11:38
add comment

It sounds like you've exhausted most normal fixes. A forced fix might come about if you go into your BIOS settings and verify that you have 'boot from removable/flash drives' set to ON.

If it is set to OFF and you toggle it ON, perhaps booting with a non-bootable flash drive in a port, the operating system may be forced to reassign how it manages flash devices. At worst it may spit out another error that could lead you to finding out what is wrong.

share|improve this answer
    
Still no on that one :'( No error either. I'm thinking it's just going to have to be a complete reinstall job :( –  matto1990 Sep 15 '10 at 23:40
add comment

Something is broken in an update I guess. Try running:

sudo mkdir /dbos 
sudo fdisk -l
# find your memory stick
sudo mount /dev/sdc /dbos
# now your memory stick is in /dbos
share|improve this answer
add comment

Solved, at least for me.

I think it is a hardware issue, because I tried a 12.04 live CD in my desktop and everything works fine. I tried at my laptop and it doesn't open the USB automatically.

Any way the solution that I found is to install usbmount by running the command below on the terminal:

sudo apt-get install usbmount

Then USB mounts fine and automatically.

More info in this page. I also installed autofs.

Hope this works for you.

share|improve this answer
add comment

USB mount only works with small drives, MY LG 500 GB didn't automount and not even with the ubuntu bug storage report... This happened with me twice... the first time I was a linux newbie and I had to format my entire disk again... and now that this happened... nothing actually works EXCEPT.. DISK UTILITY... JUST download it and go to terminal and sudo palimpsest It detects the partition, and lets u check for every kind of error there is and for the mounting issue all u gotta do is just click mount... U get a link for the mounted file and thats it... Hope this helps anyone...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.