Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire 4810T with ubuntu 10.04 installed on it. Fn+F3 should turn on/off the internal bluetooth receiver. But it does nothing. The "bluetooth" menu in System > Preferences says "your computer does not have any bluetooth adapters plugged in". I have bluez and bluez-utils installed. Other people have reported that bluetooth works out of the box on the timeline series of laptops with ubuntu. (Although others say that upgrading to a newer version of ubuntu rather than doing a fresh install can break things...)

Various things I've read on forums that it is suggested I try have failed. hcitool dev gave an empty output (Just a line that said "Devices" and nothing else.) hciconfig finished with no output. lshw | grep Bluetooth -A15 also finished with no output.

I'm not sure what the next step is in diagnosing what the problem is. What can I do now to figure out where the problem is?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

First of all check if Bluetooth is turned on in BIOS.

Make sure there are no any more switch to turn it on/off. Not with only Fn+F3

Use lsusb | grep -i bluetooth to see if system recognises you BT device.

p.s. Have you already used BT on this notebook before? Because you may have standard case with BT indicators and switches, but no BT really installed. Just asking.

share|improve this answer
    
I tried getting BT to work with the Windows that came preinstalled on it, no luck there either. I must have dreamed that it came with bluetooth... –  Seamus Sep 13 '10 at 11:11
add comment

On my Inspiron 1420N, the bluetooth radio is, internally, a USB device and specifies that in it's complete USB ID. Try lsusb | grep Bluetooth, and if that doesn't return anything, try it lowercase. If that doesn't return anything, open a new tab in the terminal, maximize it, enter sudo lshw and copy the entire thing to paste.ubuntu.com.. Then post a link here so somebody can look through it for you. You might at that point consider doing the same thing with lspci and lsusb, posting a separate Ubuntu Pastebin link to each.

share|improve this answer
add comment

You might want to check your system log with the dmesg command in a terminal. Do that after you tried to activate the device and see whether the log gives you some usefull information on what happened

share|improve this answer
    
I dumped dmesg output before and after pressing the button to two files and diffed them. No changes, apparently... –  Seamus Sep 12 '10 at 18:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.