Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know this problem has been posted before but none of the possible solutions I found worked for me. I just bought a Toshiba Satellite P50-A-11L laptop, reformated hdd, got rid of God-awful Windows 8 and installed Windows 7 Ultimate 64-bit. When I try to Install Ubuntu from LiveUSB, I get black screen as soon as I choose "install Ubuntu inside Windows" and want to proceed. Sometimes, insted of just hanging on black screen, it reboots straight back to Windows.

Other details:

  1. I installed Windows 7 in Legacy mode, not UEFI mode as in UEFI mode it refused to recognise any USB or DVD as bootable (even with safe boot and fast boot disabled).
  2. This happens with any Ubuntu version (12.04, 13.04, 13.10). Also with 13.10 version it does not even load Ubuntu from USB, just stuck on screen with "Ubuntu" and progress bar.

  3. Downloaded images were checked and after that the installation on USB stick was checked by Ubuntu. So it's not an image problem. Even tried just for the heck of it installing from the same sticks on my old laptop and everything worked fine.

  4. I tried creating USB sticks with different software (LiveLinux USB Creator, UUI, Yumi) - same result.
  5. As I am booting in Legacy mode, I used Boot-Repair first in order to make Ubuntu see that I have Windows installed.

What I tried:

  1. Disabling the in-built Lan (don't have NIC in my Bios). That actually only caused LiveUSB not to boot at all, ending in "divide error: 0000 [#1] SMP" and quoting various nouveau errors.
  2. Changing boot mode in Grub to "osi=Linux acpi_backlight=vendor" and after that to "nomodeset". Didn't work either. And I ran into another error while trying to update grub: /user/sbin/grub-probe: error: failed to get canonical path of /cow'. Tried to fix that though Boot_repair but couldn't as Grub options are grayed out and not accessible there.
  3. Tried a simple solution mentioned by someone of just increasing screen brightness using function key when the screen goes black.

Did not find any other possible solutions. I am not most advanced Linux, user so maybe I'm missing something obvious here? Any help would be appreciated :)

share|improve this question

Just answering my own problem cause maybe someone will have a temporary intelligence crash, as I had, and this will actually help :).

So I solved it. Apparently the problem was just caused by me being a temporary idiot. I completely forgot that the small "system reserved" partition created by Windows is there and counts to my partition pool. So I happily divided my drive into 3 partitions, effectively making 4 primary ones and leaving Ubuntu no room. So I just deleted one, created Ubuntu partitions manually though "Something else" (just in case) and successfully installed with no troubles what so ever.
Although I installed my "old" 13.04, not 13.10. Still can't get 13.10 liveUSB to cooperate and can't upgrade cause I get "Sorry, Ubuntu 13.04 has experienced an internal error". But that's a whole other issue and not that bugging at all.

share|improve this answer

Shut down Windows 8 while pressing the Shift key to completely power off. -Power on and press F2 while the Toshiba logo is displayed to enter the UEFI Setup Menu. -Go to the Security tab and set the "Secure Boot" setting to "Disabled". -Go to the Advanced tab, enter "System Configuration" and set the Boot Mode to "CSM Boot." -Press F10 to save and exit.

Now boot to your Win 7 disk and follow the setup instructions

Also, I expect Sysprep expects an MBR disk. So you probably need to use a partitioning tool to remove the GPT partitions. EaseUS has instructions here using its partition manager (free for personal use).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.