Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Gearman on a clean out of the box 10.04 server using the following commands:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com
sudo apt-get update
sudo apt-get install gearman-job-server libgearman2 libgearman-dev uuid-dev php5-dev
sudo pecl install channel://pecl.php.net/gearman-0.7.0

I've added the following to my /etc/apt/sources.list:

deb http://ppa.launchpad.net/gearman-developers/ppa/ubuntu lucid main

But I get the following error after I run the apt-get install:

Reading package lists… Done
Building dependency tree
Reading state information… Done
uuid-dev is already the newest version.
php5-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gearman-job-server: Depends: libdrizzle1 (>= 2010.10.01) but it is not installable
E: Broken packages

Any help would be greatly appreciated.

UPDATE:

It seems I was able to install libdrizzle with the following instructions:

sudo apt-add-repository ppa:drizzle-developers/ppa
sudo apt-get update
sudo apt-get install libdrizzle1

After this I was able to install Gearman, however, I was unable to install the PECL module. The module seems to be no longer supported. I was able to install it like this:

wget http://pecl.php.net/get/gearman-0.7.0.tgz
tar -xvfz gearman-0.7.0.tgz
cd gearman-0.7.0
./configure
make
sudo make install

More information on this page: http://gearman.org/index.php?id=gearman_php_extension

share|improve this question

3 Answers 3

up vote 2 down vote accepted

It would appear that the PPA for gearman-job-server is a little broken. I'd suggest reporting this as a bug here:

https://bugs.launchpad.net/gearmand/+filebug

That said, there is a working version of gearman-job-server in lucid, v0.10. Its a little older and doesn't have libdrizzle support, so persistence will have to be through other means, but it should work.

share|improve this answer
    
I installed that one built I'm unable to build PHP support for it. I might open that up under a new question. –  Luke May 1 '11 at 6:30

Try to change the server from your packages.

1) Click Alt + F2 and paste this gksu software-properties-gtk

enter image description here

2) Then hit enter.

enter image description here

3) Choose another server:

enter image description here

share|improve this answer
    
Sorry. I'm not sure what this is supposed to do. Could you elaborate? Thanks. –  Luke May 1 '11 at 3:22
    
Sometimes I could fix this issue by changing the server of the packages. I've edited the answer. –  desgua May 1 '11 at 4:38

I have solved this problem adding the the following repository into my repository list:

  • ppa -> ppa:gearman-developers/ppa
  • @see -> https://launchpad.net/~gearman-developers/+archive/ppa
  • I configured the repository over the synaptic. But you could do that also adding the pahts into the your source.list files and running apt-get update:

    console:

  • add lines to source.list
  • sudo apt-get-repository ppa:gearman-developers/ppa
  • sudo apt-get update
  • Synaptic:

      Synaptic->settings->repositories->add() the following ones:
    1. deb http://ppa.launchpad.net/gearman-developers/ppa/ubuntu YOUR_UBUNTU_VERSION_HERE main
    2. deb-src http://ppa.launchpad.net/gearman-developers/ppa/ubuntu YOUR_UBUNTU_VERSION_HERE main

    I did not have problems with any dependence, but depending on your version you coud be. I am using following version.

    $/lsb_release -a Distributor ID: Ubuntu Description: Ubuntu 12.04.3 LTS Release: 12.04 Codename: precise

    May be it helps someone.

    share|improve this answer

    Your Answer

     
    discard

    By posting your answer, you agree to the privacy policy and terms of service.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.