Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After this (Iomega Home Media disk corruption - data recovery help asked) problem solved... i have a new one..

I'm trying to understand why my Iomega Home Media Stopped working, and need for that to see what happened on the OS Logical Volume. For reading purpose, i will remind having a Seagate 1TO hard drive mounted /dev/sdc, running GPT, Soft Raid (on one disc : Wonder why raid ?), with LVM2 Volume groups that has a 4GB partition, a 16GB OS Partition (i need to access) and a 921GB i have managed to gain access to...

Attacking the os partition, i tried an ubuntu automount that ended with this error

Error mounting /dev/dm-1 at /media/ubuntu/6b08ba57-d9c9-46bc-af28-e57b222bad6d: Command-line `mount -t "xfs" -o "uhelper=udisks2,nodev,nosuid" 
"/dev/dm-1" "/media/ubuntu/6b08ba57-d9c9-46bc-af28-e57b222bad6d"' exited with non-zero exit status 32: 
mount: /dev/mapper/md0_vg-vol1: can't read superblock

Googling this error leads to make an File System Check which can be done only with xfs_check / xfs_repair. But problems continue here as none of these two commands work :

ubuntu@ubuntu:/$ sudo xfs_check /dev/md0_vg/vol1 
xfs_check: read failed: Input/output error
xfs_check: cannot init perag data (5)
xfs_check: read failed: Input/output error
XFS: failed to find log head
ERROR: cannot find log head/tail, run xfs_repair

ubuntu@ubuntu:/$ sudo xfs_repair /dev/md0_vg/vol1 
Phase 1 - find and verify superblock...
superblock read failed, offset 4293918720, size 131072, ag 1, rval -1

fatal error -- Input/output error

What can i do to solve this and recover data on this OS partition, or even better restore partition to an active state... Is the hard disk failing ?

EDIT : To complete informations, here is the mtab :

root@ubuntu:/home/ubuntu# cat /etc/mtab
/cow / overlayfs rw 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
/dev/sdd1 /cdrom vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0
/dev/loop0 /rofs squashfs ro,noatime 0 0
none /sys/fs/cgroup tmpfs rw 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
none /run/user tmpfs rw,noexec,nosuid,nodev,size=104857600,mode=0755 0 0
none /sys/fs/pstore pstore rw 0 0
systemd /sys/fs/cgroup/systemd cgroup rw,noexec,nosuid,nodev,none,name=systemd 0 0
gvfsd-fuse /run/user/999/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,user=ubuntu 0 0
/dev/sda2 /media/ubuntu/70E04BA9E04B73FE fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/mapper/7ebf5eba_vg-lv28ab8112 /media/ubuntu/594eab64-3663-4ace-bbb0-aebe31772a0d xfs rw,nosuid,nodev,uhelper=udisks2 0 0
/dev/sda1 /media/ubuntu/78AE5DC4AE5D7B96 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sdb1 /media/ubuntu/7EA4E8DBA4E896C5 fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/loop1 /media/ubuntu/f24d667d-d64f-6540-b023-4f1d53e8c97c ext2 rw,nosuid,nodev,uhelper=udisks2 0 0
/dev/mapper/md0_vg-BFDlv /media/ubuntu/b54e7759-4a09-4514-bc1d-f0dbd8570896 ext2 rw,nosuid,nodev,uhelper=udisks2 0 0

Hope it help understanding problem ...

share|improve this question

2 Answers 2

Is it possible that this lv is not of the xfs type ? (if it's for an operating system, maybe it more likely to be ext3 or ext4).

could you try file -s /dev/md0_vg/vol1 ?

share|improve this answer
    
here is the result of the command : root@ubuntu:/home/ubuntu# file -s /dev/md0_vg/vol1 /dev/md0_vg/vol1: symbolic link to '../dm-2' –  tdldp Dec 5 '13 at 19:19
    
@tdldp then what prints ˋfile -s /dev/dm-2ˋ –  Emmanuel Dec 5 '13 at 20:51

Emmanuel sorry for late answer to your demand : Here is the result :

root@ubuntu:/dev# file -s /dev/dm-2 /dev/dm-2: SGI XFS filesystem data (blksz 4096, inosz 256, v2 dirs)

It is a XFS filesystem as it declares, but cannot get in it and get files back... Is the harddrive failing ?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.