Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since yesterday, after last system upgrade, compiz CPU usage has gone wild :

horacio@horacio-xps13:~$ top

top - 15:09:10 up  3:31,  2 users,  load average: 2,62, 2,75, 2,59
Tasks: 261 total,   2 running, 259 sleeping,   0 stopped,   0 zombie
%Cpu(s): 50,1 us,  4,6 sy,  0,0 ni, 45,1 id,  0,2 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem:   7731228 total,  6252616 used,  1478612 free,   239548 buffers
KiB Swap: 15871996 total,        0 used, 15871996 free,  1451684 cached

  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND                                                                                                       
 2394 horacio   20   0 1929m 407m  44m S 126,3  5,4  80:07.62 compiz                                                                                                        
 5908 horacio   20   0 3242m 2,1g  59m S  60,2 28,6  30:27.73 firefox                                                                                                       
 1163 root      20   0  697m 433m  72m S  25,3  5,7  14:48.66 Xorg                                                                                                          
 6017 horacio   20   0  905m 263m  34m S   4,0  3,5   2:07.85 plugin-containe                                                                                               
 6669 horacio   20   0  707m  20m  13m S   3,0  0,3   0:01.31 gnome-terminal                                                                                                
 6989 horacio   20   0 24876 1708 1128 R   0,7  0,0   0:00.05 top                                                                                                           
 2374 horacio   20   0 20236  940  768 S   0,3  0,0   0:05.01 syndaemon                                                                                                     

That while doing nothing besides Firefox, if I open other programs it goes worse. The fun works without stop, it is definitively not normal.

When I start a Lubuntu session (no compiz), I have no problem.

Any idea? Any suggestion? Please?

Using Ubuntu 13.10 on a Dell XPS 13 Developer Edition, with an Intel graphics card.

This is the result of lspci:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QS77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
share|improve this question

1 Answer 1

This seemed to work for some people. Maybe it can work for you. http://followthegeeks.com/compiz-is-consuming-too-much-cpu-heres-the-solution/ (in case link goes down) Open compizconfig Go to OpenGL Turn off wait for Vsync That's it.

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.