Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried to install new software like QT Creator, Visual Studio and Google Chrome, but it will not install and it shows me an error saying: check your internet connection.

share|improve this question

closed as unclear what you're asking by dobey, guntbert, Braiam, Seth, Luis Alvarado Dec 9 '13 at 0:37

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Well did check your internet connection? How are you installing? –  Mitch Dec 5 '13 at 12:34
    
i got Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package chromium-browser –  nikhil Dec 5 '13 at 13:14
    
Tell your system to update the latest list of software from each archive it knows about by running the command: sudo apt-get update. If that command runs and finishes without any errors, then run: sudo apt-get install chromium-browser. –  karel Dec 5 '13 at 13:26
    
I hope you've got a fresh install and not an upgrade from an older version of Ubuntu, otherwise you'll have to check your /etc/apt/sources.list file for outdated software source lines in it. –  karel Dec 5 '13 at 14:48
1  
The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  guntbert Dec 5 '13 at 21:37
add comment

1 Answer 1

Since you possibly wrote your question from your computer, it seems likely that you have an internet connection, but you can't connect to the server to download any new software. So open the Software Sources window and check what server you are using to download your software and updates. In Ubuntu 12.04 open the Ubuntu Software Center and select Edit -> Software Sources -> Ubuntu Software tab. In Ubuntu 12.10 open System Settings from the Launcher, click on the Software Sources icon and in the Software Sources window select the Ubuntu Software tab. In Ubuntu 13.04 and 13.10, search for "software" in the Dash, click on the Software & Updates icon and in the Software & Updates window select the Ubuntu Software tab.

In the Ubuntu Software tab after where it says: Download from: select the server nearest to you, or if you have already selected the server nearest to you, try selecting a different server. An Authenticate window will appear asking you to authenticate with your user password to change the server that you download software and updates from.


If this doesn't work, another possibility is that you have somehow lost administrative privileges. You would know this immediately if you tried running a sudo command in the terminal and it didn't accept your password there or anywhere else where you needed to type your administrative password. In that case you should look at the answers to the question: How do I reset a lost administrative password?.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.