Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop hates Nouveau, and to save me the bother of upgrading from 10.04 to 11.04 (as I did with 10.10) I was wondering if there was a way to modify an Ubuntu ISO to run on the nVidia drivers instead of having t to install them afterwards.

I don't really want to switch to Mint, as I do love Unity.

So, is there a way for me to get/create an ISO with the nVidia drivers already installed and active?

EDIT: LiveCD system won't boot with Nouveau, and installing through alternate or any other method results in Nouveau being activated after installation, leaving me with a black screen, aside from the cursor. Hence why I'm asking about getting the NVIDIA drivers up and running.

share|improve this question
    
What's so hard about installing them after? –  RolandiXor Apr 30 '11 at 23:31
1  
I took "My laptop hates Nouveau" to mean "My laptop just wont boot with nouveau enabled" –  Oli Apr 30 '11 at 23:33
    
Oli is correct. My machine, be it in live mode or installed, will simply not boot to the desktop with Nouveau –  Dante Ashton May 1 '11 at 7:56
add comment

2 Answers

Your problem is with nouveau so I'd suggest just blacklisting it so it never gets loaded. Normally speaking this would be done by editing /etc/modprobe.d/blacklist.conf but that's not really feasible in a live setting.

But you can still do it using a boot parameter.

  1. Mash the keyboard as soon as the LiveCD starts booting (after BIOS). I mashed F6 (on a hunch) and it worked - but other keys will probably work too.
  2. Select your language and press F6 again.
  3. Press escape to get out of that submenu and you should be left with a boot parameter line.
  4. Add disablemodules=nouveau after the --, right at the end of the line and hit return.

This should get you to the desktop in VESA mode. From there you should be able to install.

Before you reboot, I suggest you mount the new installation and edit its etc/modprobe.d/blacklist.conf file to add blacklist nouveau on a new line. If you don't do this you can do it later by doing the disablemodules-route in grub. See the Boot Options help page for more on this.

Once you're sitting on your VESA version of the desktop, you can install the nvidia driver without any issue.


Alternatively:

  1. Download the alternate ISO and boot to that. This is a text-mode installer. Bit rawer in places but it should get Ubuntu installed.
  2. Interfere with grub (as above) when you boot the first time.
share|improve this answer
    
I did try xforcevesa on the boot options, but it has no effect in 10.10 or 11.04 (though 10.04 goes to 'low graphics mode') –  Dante Ashton Apr 30 '11 at 23:58
    
xforcevesa boot option works in 10.04. In later versions, try nomodeset instead. –  Subhash Jun 10 '11 at 4:32
    
For me worked Oli's №1 and №2, after that I just chose "nomodeset" option and Ubuntu finally booted with it. Thanks, Oli! –  Shein Alexey Sep 21 '13 at 18:30
add comment

Have you tried booting the livecd / your installed alternative ISO desktop with the kernel command line option:

nouveau.noaccel=1

Or if this doesn't work, perhaps the good old:

nouveau.modeset=0

Nouveau hard locks my MacBook Pro 5,1 when booting but using the noaccel option allows it to boot successfully so it may work for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.