Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My input is:

sudo apt-get install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev

and the output is:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies.

libsdl-image1.2-dev : Depends: libjpeg-dev
Depends: libtiff4-dev but it is not going to be installed

libsdl1.2-dev : Depends: libglu1-mesa-dev but it is not going to be installed

Depends: libpulse-dev but it is not going to be installed
Depends: libxt-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How do I fix this?

share|improve this question
add comment

3 Answers

To fix unmet dependencies, use sudo apt-get -f install.

share|improve this answer
    
i did that already and it doesnt work –  rahman Dec 4 '13 at 18:51
add comment

You may have to enable the "Source code" repository in the Software and Updates program.

share|improve this answer
    
i enabled the source code and repeated what you said however im still ending with the same output –  rahman Dec 4 '13 at 18:57
    
Try running sudo apt-get update before trying again. –  searchfgold6789 Dec 4 '13 at 18:58
add comment

Try this one:

sudo apt-get install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev libpulse-dev libxt-dev

If that doesn't work you may use aptitude:

sudo apt-get install aptitude
sudo aptitude install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev libpulse-dev libxt-dev
share|improve this answer
    
i typed it in however when i try to compile an sdl program it wont compile; –  rahman Dec 4 '13 at 19:03
    
the output of the command is: Need to get 0 B of archives. After unpacking 0 B will be used. perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = "en_GB.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory –  rahman Dec 4 '13 at 19:13
    
@rahman can you edit your question instead please. –  Braiam Dec 4 '13 at 20:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.