Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 13.10 with kernel 3.11.0-14-generic.

Everything was working fine, but then I did a routine software update and the computer would then not boot. Unfortunately, I'm not sure what software was updated, but I get the feeling it modified my grub configuration (more on why later).

Booting would freeze on "Loading initial ramdisk" regardless of whether I tried regular or recovery mode for both 3.11.0-14 and 3.11.0-12 kernels.

While poking around, I ran into a solution that allows me to boot: Drop into a grub> command prompt by pressing c at the advanced boot options menu. Insert the linuxefi module by typing

insmod (hd0,gpt7)/usr/lib/grub/x86_64-efi/linuxefi.mod

where hd0,gpt7 is my linux partition.

After that, I pressed ctrl-alt-delete which seemingly reboots (hear the computer beep, and am offered grub options again). However, now when I select any of the boot options (default or recovery mode), the computer boots fine.

If, however, I do a real reboot, I get back to the same "loading initial ramdisk" freeze.

So how can I make the insertion of the linuxefi module permanent? I'm assuming I should do this in one of the grub config files, but not sure which one.

Additional ideas on what caused this mess would be appreciated as well.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's conceivable that the Boot Repair tool would fix this problem; however, I've never heard of your specific problem before, so I can't promise that this will do the trick.

Another thing you can try (and with essentially no risk) is to prepare a USB flash drive or CD-R of my rEFInd boot manager. (There are download links for both types of images on that page.) If rEFInd can boot Linux (and any other OS, if you're multi-booting), then you can install the Debian-package version of the program to have it take over from GRUB. Note that rEFInd will probably give you options to boot via GRUB (which likely won't help) or to boot the Linux kernel (vmlinuz option(s)) directly; the latter option is what you should try.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.