Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently chose to try out Ubuntu 13.10 64-bit on my laptop and the graphics seems to be slightly worse than it used to be on Windows 7. I have a Intel graphic card by the way, and I've read that Intel is supposed to be almost fully supported on Linux. Also I have seen other Linux desktops for instance, and the icons seems to be sharper and better looking compared to mine. It might be an easy answer to my problem, I downloaded a driver from HP's home page, but I cannot figure out how to install it. Everything on my computer looks blurry, except if I watch a movie in VLC. Does anyone have an answer to my problem? I am a thankful newbie for every answer I can get :)

Edit: xrandr -q gives this output:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
LVDS connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 310mm x 174mm
   1366x768       60.0*+   40.0  
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-2 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
share|improve this question
Sounds like your desktop doesn't use the correct resolution. Please open a terminal, enter xrandr -q and add the output of that command to your question. –  drc Dec 4 '13 at 16:04
I was thinking resolution but that it looks fine in vlc seems weird to me. in general I would not advise to download software or drivers from a website in ubuntu. you can have a look under system settings --> software and updates --> 'additional drivers'-tab and see if there is something available but I thought Intell drivers should be build into the kernel... –  Wouter Dec 4 '13 at 16:10
Went into system settings, it says "No proprietary drivers in use". Does that give you any ideas? –  alv Dec 4 '13 at 16:13
Problem solved! –  alv Dec 4 '13 at 16:55
It would be nice to share your solution by editing your question or adding an answer. This way other people may benefit from your experience. –  hmayag Dec 4 '13 at 17:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.