Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have HP Probook 440G1 with Integrated AMD graphics (mars) (discrete) and Intel core i7 Haswell as integrated. I had installed Ubuntu 13.10. but, by default the AMD graphics was not installed. tried the method above, the unity desktop gets completely broken on reboot. Two things happened while installing:-

  1. I downloaded the beta drivers from the AMD site. After doing sudo ./amd_xxxxx.run, the AMD GUI came up, but, all the captions in the GUI were missing only some buttons were visible, so I could not go ahead.

  2. I tried the way shown here (http://ubuntuforums.org/showthread.php?t=1930450), I could not install ia32-libs (it seems the package is not available and gave some options,installed all the suggested options), everything went well, then when I did sudo aticonfig --initial -f, it gave an error that fgrlx was not found in /usr/lib.

so, the question is, in which ubuntu version can I completely support AMD graphics of 8xxx variety. Thanks in advance! Regards, Manoj

share|improve this question
    
It should work OOTB, are you able to reproduce this? –  Braiam Feb 9 at 3:50
add comment

1 Answer 1

I got it working. In fact I had to wait.after logging in It takes upto 2 minutes to load the unity desktop, till then it is black screen with pointer. ia32-libs is not required for Ubuntu 13.10 and the open source drivers don't detect the 8750M hardware.(not yet). So, downloading the driver binary and installing as mentioned in the post above worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.