Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already have a keyboard short-cut that works for tmux

I mapped: Ctrl+Alt+B to the command: gnome-terminal -e tmux

BUT when I open up vim in the tmux session started by this the colors don't work correctly.

I fixed the initial tmux vim colorscheme issue outside by adding the 256 color statement to my .tmux.conf and .bashrc

so when I regularly tmux into my terminal and vim it's fine.

So the problems comes in at gnome-terminal -e tmux ? where this somehow disables 256?

I've tried gnome-terminal -e tmux -2 for the 256 color flag but this won't let the key binding work. Is there some other mapping or something or another way to make a keyboard shortcut for tmux that'll help me with this slight convenience issue?

Thanks.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.