Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Gnome Shell with Ubuntu 13.10. I always used layout switching with Alt+Shift. After upgrade to 13.10, the layout can also be switched by pressing both shifts simultaneously. How do I prevent that?

I tried e.g. gsettings list-recursively | grep -i shift which didn't reveal any Shift_L+Shift_R or grp:shifts_toggle value.

After reading through Change Keyboard Layout with both left and right Alt + Shift combos I also tried:

setxkbmap us,cs,de -option ""
setxkbmap us,cs,de -option "grp:alt_shift_toggle"

After the first setxkbmap, I couldn't switch layout with either shortcut. After the second setxkbmap, both shortcuts worked again :-/

Is this a bug?

By the way, I also disabled the now default <Super>+Space because it anyway didn't work properly either.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.