Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a I210 Gigabit Network Connection and it requires me to install the driver manually, the driver is igb-5.0.6 .

So this is what I do:

sudo make install

sudo modprobe igb

Then everything works fine.

My Ubuntu 12.04 automatic updates is enables and whenever it runs it requires me to reboot and after that my eth* is gone.

How do I stop the updates to make my network driver go missing or any other solutions?

modinfo igb

filename:       /lib/modules/3.2.0-57-generic/kernel/drivers/net/igb/igb.ko
version:        5.0.6
license:        GPL
description:    Intel(R) Gigabit Ethernet Network Driver
author:         Intel Corporation, <e1000-devel@lists.sourceforge.net>
srcversion:     7D5C0C9D2D9DF9F98067FA5
alias:          pci:v00008086d000010D6sv*sd*bc*sc*i*
alias:          pci:v00008086d000010A9sv*sd*bc*sc*i*
alias:          pci:v00008086d000010A7sv*sd*bc*sc*i*
alias:          pci:v00008086d000010E8sv*sd*bc*sc*i*
alias:          pci:v00008086d00001526sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Dsv*sd*bc*sc*i*
alias:          pci:v00008086d000010E7sv*sd*bc*sc*i*
alias:          pci:v00008086d000010E6sv*sd*bc*sc*i*
alias:          pci:v00008086d00001518sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Asv*sd*bc*sc*i*
alias:          pci:v00008086d000010C9sv*sd*bc*sc*i*
alias:          pci:v00008086d00000440sv*sd*bc*sc*i*
alias:          pci:v00008086d0000043Csv*sd*bc*sc*i*
alias:          pci:v00008086d0000043Asv*sd*bc*sc*i*
alias:          pci:v00008086d00000438sv*sd*bc*sc*i*
alias:          pci:v00008086d00001516sv*sd*bc*sc*i*
alias:          pci:v00008086d00001511sv*sd*bc*sc*i*
alias:          pci:v00008086d00001510sv*sd*bc*sc*i*
alias:          pci:v00008086d00001527sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Esv*sd*bc*sc*i*
alias:          pci:v00008086d00001524sv*sd*bc*sc*i*
alias:          pci:v00008086d00001523sv*sd*bc*sc*i*
alias:          pci:v00008086d00001522sv*sd*bc*sc*i*
alias:          pci:v00008086d00001521sv*sd*bc*sc*i*
alias:          pci:v00008086d00001539sv*sd*bc*sc*i*
alias:          pci:v00008086d0000157Csv*sd*bc*sc*i*
alias:          pci:v00008086d0000157Bsv*sd*bc*sc*i*
alias:          pci:v00008086d00001538sv*sd*bc*sc*i*
alias:          pci:v00008086d00001537sv*sd*bc*sc*i*
alias:          pci:v00008086d00001536sv*sd*bc*sc*i*
alias:          pci:v00008086d00001533sv*sd*bc*sc*i*
alias:          pci:v00008086d00001F45sv*sd*bc*sc*i*
alias:          pci:v00008086d00001F41sv*sd*bc*sc*i*
alias:          pci:v00008086d00001F40sv*sd*bc*sc*i*
depends:        dca
vermagic:       3.2.0-57-generic SMP mod_unload modversions 
parm:           InterruptThrottleRate:Maximum interrupts per second, per vector, (max 100000), default 3=adaptive (array of int)
parm:           IntMode:Change Interrupt Mode (0=Legacy, 1=MSI, 2=MSI-X), default 2 (array of int)
parm:           Node:set the starting node to allocate memory on, default -1 (array of int)
parm:           LLIPort:Low Latency Interrupt TCP Port (0-65535), default 0=off (array of int)
parm:           LLIPush:Low Latency Interrupt on TCP Push flag (0,1), default 0=off (array of int)
parm:           LLISize:Low Latency Interrupt on Packet Size (0-1500), default 0=off (array of int)
parm:           RSS:Number of Receive-Side Scaling Descriptor Queues (0-8), default 1, 0=number of cpus (array of int)
parm:           VMDQ:Number of Virtual Machine Device Queues: 0-1 = disable, 2-8 enable, default 0 (array of int)
parm:           max_vfs:Number of Virtual Functions: 0 = disable, 1-7 enable, default 0 (array of int)
parm:           MDD:Malicious Driver Detection (0/1), default 1 = enabled. Only available when max_vfs is greater than 0 (array of int)
parm:           QueuePairs:Enable Tx/Rx queue pairs for interrupt handling (0,1), default 1=on (array of int)
parm:           EEE:Enable/disable on parts that support the feature (array of int)
parm:           DMAC:Disable or set latency for DMA Coalescing ((0=off, 1000-10000(msec), 250, 500 (usec)) (array of int)
parm:           LRO:Large Receive Offload (0,1), default 0=off (array of int)
parm:           debug:Debug level (0=none, ..., 16=all) (int)
share|improve this question
    
i think the process is something like "./configure" then "make" then finally "sudo make install", isnt it?? –  Sushantp606 Dec 3 '13 at 10:11
1  
Usually I would build things like this, but I don't think it's the case this time. The build is fine. The problem is it loses the drives from modprobe after the update/reboot –  id10t1 Dec 3 '13 at 10:17

1 Answer 1

up vote 0 down vote accepted

You have to tell the kernel to load this module at boot time.

sudo echo igb >> /etc/modules

and then it should work.

UPDATE: Sorry, I misunderstood the problem. I thought is was a general problem with the driver modprobe not surviving reboot. The problem is system updates and kernel updates that happen automatically do not include this 3rd party driver you are using. Have a look at DKMS to have the module build again as part of the update process:

https://help.ubuntu.com/community/DKMS

share|improve this answer
    
Will try this and let you know. I need to re-install the driver after every time it auto updates. thanks –  id10t1 Dec 3 '13 at 12:38
    
No sorry it does not work. I need to do this over "sudo make install" "sudo modprobe igb" to make it work –  id10t1 Dec 3 '13 at 14:58
    
I changed it to sudo echo ... but the real idea is to make sure there is a line in /etc/modules for igb, so you could just edit /etc/modules and add "igb" with an editor if you prefer. –  Joseph Santaniello Dec 3 '13 at 16:06
    
I updated my answer above once I realized I had misunderstood your question. –  Joseph Santaniello Dec 3 '13 at 21:10
    
I thank you kind sir. –  id10t1 Dec 4 '13 at 9:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.