Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell 8700 with Windows 8 and I'm trying to have a dual boot option. This is my first experience with Ubuntu or any Linux distro. I'm working with Ubuntu 13.10. I followed the tutorial found at this site: http://www.everydaylinuxuser.com/2013/09/install-ubuntu-linux-alongside-windows.html. I created the partitions as indicated in this article alotting 100gb to the Ubuntu install. 50gb to /, about 34 for the remainder, and 16 for a swap.

Upon completion of the tutorial grub loaded with the first boot and I was able to load Ubuntu. I tried restarting and loading Windows from the grub menu. No luck. For the life of me, I can't remember the error...it was several hours ago now.

I did as the tutorial suggests and use boot-repair. I went through the process and no improvement. In fact, I think I may have done something I shouldn't have in the process. Now I simply get a "no bootable devices found" error when trying to boot my machine.

My boot type is now UEFI. I have also disabled SecureBoot.

At this point I'm hoping someone can point me in the right direction. I've searched and tried several things, but given I'm a noob, I'm not sure if I'm even barking up the right tree.

In conclusion, my question is "What is the best way to solve the problem of my machine not booting to either Windows 8 or Ubuntu after a potentially botched install?" I'm thinking about trying to restore the machine with my recovery media, but will that restore the BIOS/UEFI stuff? If I could get back to square one I wouldn't hesitate to start over and try it again. I appreciate your time and help! Thank you!

Edit: As requested, here is the most recent link from boot-repair: See below, second edit.

While I'm not exactly sure "what" I did, I'm certain it's a conflict between using UEFI and Legacy boot processes. I just can't seem to get the settings back to the right combination to allow me to even boot to one or the other, let alone select which OS to boot. Thanks again for your help!

Second Edit: I did a little more research and looking around this AM. I now have the system booting, but get a /grub/i386-pc/normal.mod file not found and a grub rescue prompt. Should I just reinstall grub into my boot designated partition?

Here is my most recent boot repair: http://paste.ubuntu.com/6514358/

Thanks again for your help!

share|improve this question
Sounds like you're looking for repair your grub. That should be an answered question on this site if you search for it. Then you might have to manually add an entry in order to boot Windows. But since you don't know what you did and don't know what errors you got, it's difficult to provide a very precise answer. –  Jo-Erlend Schinstad Dec 3 '13 at 7:18
Welcome to Ask Ubuntu. Could you fire up Boot-Repair once more and select the "Create Bootinfo summary". Please then edit your question and add the linked URLs Boot-Repair provides you. –  MadMike Dec 3 '13 at 8:19
MadMike, I just added the link to the summary. Jo-Erlend Schinstand, I'll keep searching, what other info can I provide to help you guys help me? Thanks! –  jtesta Dec 3 '13 at 12:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.