Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems booting xUbuntu on an ASRock UEFI motherboard

I have an following hardware I'm trying to setup with xUbuntu 12.04.3:

  • AMD processor
  • ASRock 970 Extreme 4 AM3+ Motherboard
  • 16GB Patriot mini USB drive

My steps to install a bootable and persisted xUbuntu USB drive follows:

On my Mac

  1. Create a LiveUSB from my Mac to 4GB Sandisk USB using unetbootin as the installer
  2. Format the 16GB Patriot USB drive on my MAC to FAT32/MBR

Installation Process

Plug both USBs to the motherboard Change Bios to boot USB drives (First = 16GB Patriot Persisted Drive; Second = 4GB Sandisk LiveUSB) Press F11 and selected to boot 4GB Sandisk LiveUSB Selected and installed xUbuntu on 15GB Patriot Drive

Once it finished doing this install; I restarted and got the following:

  • Can not find operating system
  • A tried to force boot the Persisted drive (on the motherboard you can either select USB:Patriot or UEFI:Patriot

I ran boot-repair and thought it solved the problem. But when I shutdown or restart xBunutu and goes to either 'Cannot find OS' or 'efidsk error' or the 'grub minimal screen'

The only way I can get xBunutu to boot is to press F11 and select 'UEFI:Patriot' on the boot loader. But sometimes, I have to restart multiple times and press F11 and select 'UEFI:Patriot' before it will load the GRUB menu.

To solve this problem, I'd like to know what's happening and if I can get xUbuntu to load without problems and directly to the OS (without seeing the GRUB menu)

Sorry for the long question. Looking forward to learning and appreciate any insights.

Thanks in advance :) WD

share|improve this question
    
Did you reformat the 16G drive to ext2 or ext4? FAT32 is not a filesystem on which you can install Ubuntu. –  ubfan1 Dec 3 '13 at 1:52
    
Hi ubfan1, thanks for taking the time to respond. During the xUbuntu install I did create a new partition (through the installer) and let xUbunutu do the rest with the 16GB drive. I will take a look at the USB when I get home. –  Wasabi Developer Dec 4 '13 at 4:34
    
Might be bug #732677, with your usb to usb install. Check the generated grub.cfg file and make sure that uuids were used in all places, partitcularly on the kernel line for root=. You can just edit the grub lines yourself to use the correct device for a boot, then run sudo update-grub. –  ubfan1 Dec 4 '13 at 5:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.