Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my Ubuntu 12.04 system to 13.10 using a bootable USB. After upgrading I tried to remove old version kernels that appeared in grub boot menu, using the Synaptic Package Manager. But old kernel packages (example: linux-image 3.2.0-52-generic, 3.2.0-23-generic) do not appear in Synaptic. When I try to update GRUB, I see the kernels there. How can I remove them properly?

Tried everything: Command line, Synaptic, Ubuntu tweak but it does not display. But during boot it always shows up. How to remove these kernel versions from old release?

dpkg -l | grep linux-image

ii  linux-image-3.11.0-14-generic 3.11.0-14.21 i386 Linux kernel image for version 3.11.0 on 32 bit x86 SMP

ii  linux-image-extra-3.11.0-14-generic 3.11.0-14.21 i386 Linux kernel extra modules for version 3.11.0 on 32 bit x86 SMP

ii  linux-image-generic 3.11.0.14.15 i386 Generic Linux kernel image


ls /boot | grep vmlinuz

vmlinuz-3.11.0-14-generic

vmlinuz-3.2.0-23-generic-pae

vmlinuz-3.2.0-52-generic-pae


cat /boot/grub/grub.cfg | grep menuentry | cut -c -80

if [ x"${feature_menuentry_id}" = xy ]; then

  menuentry_id_option="--id"

  menuentry_id_option=""

export menuentry_id_option

menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menu

submenu 'Advanced options for Ubuntu' $menuentry_id_option 'gnulinux-advanced-4f

    menuentry 'Ubuntu, with Linux 3.11.0-14-generic' --class ubuntu --class gnu-lin

    menuentry 'Ubuntu, with Linux 3.11.0-14-generic (recovery mode)' --class ubuntu

    menuentry 'Ubuntu, with Linux 3.2.0-52-generic-pae' --class ubuntu --class gnu-

    menuentry 'Ubuntu, with Linux 3.2.0-52-generic-pae (recovery mode)' --class ubu

    menuentry 'Ubuntu, with Linux 3.2.0-23-generic-pae' --class ubuntu --class gnu-

    menuentry 'Ubuntu, with Linux 3.2.0-23-generic-pae (recovery mode)' --class ubu

menuentry 'Memory test (memtest86+)' {

menuentry 'Memory test (memtest86+, serial console 115200)' {

menuentry 'Windows 7 (loader) (on /dev/sda3)' --class windows --class os $menuen
share|improve this question
    
Can you add the outputs of the following commands to the original question: dpkg -l | grep linux-image, ls /boot | grep vmlinuz*, and cat /boot/grub/grub.cfg | grep menuentry | cut -c -80. –  mikewhatever Dec 2 '13 at 21:57
    
How do I remove those old kernels now? –  Harsha Jk Dec 3 '13 at 16:37
    
You can try deleting the vmlinuz-3.2* files, and then update grub with sudo update-grub. –  mikewhatever Dec 3 '13 at 20:38
    
@mikewhatever I was also thinking of the same thing and it worked. Thanks. –  Harsha Jk Dec 8 '13 at 7:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.