Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 13 x64

I get to recovery mode via GRUB, which shows:

linux /boot/vmlinuz-2.6.32-53-generic root=UUID=4a08b936-569c-4ba6-9\607-00d05f121917 ro single

however, when I choose to boot into this mode, the system hangs at:

mount.nfs:  Connection timed out
mountall: mount /usr/local/backups [759] terminated with status 32

It will continue to repeat this if left alone...

  1. I was under the impression that single user mode would bypass mount attempts;
  2. How do you tell the system NOT to attempt to execute the mountall command?

Clearly, I need to solve the nfs problem, but if I can't get the machine to boot I'm at a disadvantage.

This is a virtual machine instance, so running a LiveCD doesn't appear to be an option.

share|improve this question
    
Boot a live CD, mount your root partition somewhere such as /mnt, then edit /mnt/etc/fstab and edit out the nfs mount(s). –  bodhi.zazen Dec 2 '13 at 21:14
    
I see no way to pull that off, given that it is a virtual machine instance (edited original message to reflect that important item). Thanks! –  Sam Spade Dec 2 '13 at 21:27
    
Boot your virtual machine from an iso file. Your virtualmachine will see the ubuntu .iso as a CD. –  bodhi.zazen Dec 2 '13 at 21:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.