Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Kubuntu 12.04 on Acer Aspire 5738ZG. Wireless HW:

lspci -k
03:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: Foxconn International, Inc. T77H047.31 802.11bgn Wireless Half-size Mini PCIe Card [AR9283]
    Kernel driver in use: ath9k
    Kernel modules: ath9k

Tried using network-manager in the beginning, then replaced it with wicd, back with network-manager again (though missing the status icon and if I run nm-applet then the icon will appear twice).

Here's my /etc/resolv.conf:

nameserver 8.8.8.8
nameserver 156.154.70.1
nameserver 208.67.222.222
search home.gateway

The problem is that I can browse the internet only after I've visited an IP, like (http://) 173.194.40.241 (www.google.com) - after this everything works great.. but why doesn't it work right away - what must I do?

Pinging the gateway (router) IP: 192.168.0.254 or www.google.com (or the IP) FAILS until I visit the IP with my web browser beforehand, which magically makes the pinging successful. IP-configuration seems to be OK:

ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:2d:79:f7:7c  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr c4:17:fe:17:fa:63  
          inet addr:192.168.0.103  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::c617:feff:fe17:fa63/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1536 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1600 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:947070 (947.0 KB)  TX bytes:299593 (299.5 KB)

I've also added this configuration but I'm unsure whether it is needed or not:

cat /etc/modprobe.d/ath9k.conf
options ath9k nohwcrypt=1

UPDATE 2013-12-06

The nohwcrypt=1 does not seem to be necessary, though many sources around the internet recommend it.

I currently have the additional name servers configured, but there probably is no need for them either.

I have not made any additions to the /etc/modprobe.d/blacklist.conf, many sources around the internet suggest putting acer_wmi there, but for me the command rfkill list does not display anything as blocked.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I've encountered the same problem (Ath9k driver. Wireless connects, but no internet until I visit an IP address). Other devices (android phone, PS3) using the same wifi router did not encounter this issue.

Managed to resolve it using two different methods:

1) Turn off Wireless N on the router

My problem only started when I switched from a B/G only router to a B/G/N router. I suspected the problem may be due to wireless N, so I disabled it on my router (the ath9k driver don't allow you to disable this). Everything works fine after that.

2) Update router firmware

I'm using an ASUS RT-N56U, with firmware version 1.0.1.8t. I realized that the latest version of the firmware is 3.0.0.4.374.979, and that the changelog includes "2.4Ghz compatibility issue for some specific devices". After updating to the latest router firmware, the internet connection works normally even with Wireless N.

share|improve this answer
    
Thanks! I actually thought I had disabled router's n from b+g+n but I probably hadn't saved the config then - you got me thinking and recheck. A few days ago I found out that the wlan-device in my Acer Aspire 5738ZG, which is AR928X, is based on a 802.11n draft: askubuntu.com/questions/216575/… (see comments), which might have something to do with the issue. I am satisfied. –  heikkim Dec 5 '13 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.