Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having difficulty automatically mounting my disk drive to a folder inside my home directory. I have found that If I add the line

UUID=0dc6753f-fd25-4f30-aac8-95aae93873ce /home/stuart/extra_storage ext4 defaults 0 2

to my /etc/fstab and then perform sudo mount -a all is swell, but if I reboot, the files do not appear inside that directory. However, if I change the mount path to /mnt/extra_storage then there are no problems. I believe this may have something to do woth the encrypted home directory option I selected during the Ubuntu installation. Can anyone confirm that this is the case and whether there is a way to resolve this?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.