Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to remove the nvidia video driver and revert to the xorg, but I haven't been able to boot in recovery mode. Any suggestions ?
I can boot from the installation disk, in the live disk mode, and edit/add/remove files.

I tried a few things:
1. Ctrl-Alt-F1 to F4 don't take me to a command line where I can try something.
2. The "left-shift" button during boot or the "ESC" button during boot don't seem to work for me.
3. I copied /etc/X11/xorg.conf.failsafe to xog.conf, and then tried rebooting, and it didn't work either.
4. I edited /etc/default/grub to try a few things:
* Changed the parameter GRUB_DEFAULT to 1, 2, and 3 (instead of 0)
* Commenting out GRUB_HIDDEN_TIMEOUT=0 and GRUB_HIDDEN_TIMEOUT_QUIET
* Enabling GRUB_GFXMODE=640x480

FYI:
I installed Ubuntu 13.10 on a desktop with nvidia GeForce 210 video card.
(Motherboard: MSI K8N Neo4 Platinum “MS-7125”m, with newest BIOS: V1.D, 250 GB SATA HDD, SATA DVD/CD drive, 4 GB RAM.)
Then I changed the driver to the NVIDIA driver 319, and now Ubuntu doesn't get to the initial login screen anymore.

share|improve this question
    
Run the live disc, and chroot into your system. Remove the nvidia packages with apt-get. That should fix it. (No warranty included.) gentoo.org/doc/en/handbook/… (THIS PART: Mounting the necessary Filesystems AND THIS: Entering the new Environment . And next time set up SSH on your own PC with private keys. So if you have a laptop, or you can borrow one, it's easier to fix issues.) –  Shiki Dec 1 '13 at 23:09
    
Shiki: Thank you for the suggestion. I'm not familiar with chroot, so I'll do some reading before trying it (hopefully soon). –  Edgardo Dec 2 '13 at 5:54
add comment

1 Answer 1

up vote 0 down vote accepted

Thanks to Shiki's chroot suggestion, here is how I was able to revert to the open source display driver:
Reference: http://www.tuxation.com/chrooting-into-a-linux-environment.html

I started booting with the Ubuntu 13.10 installation disk, selecting to "Try" Ubuntu.
Then I opened a terminal window (clicked on the upper left corner icon, and typed: Terminal, to find it)
Then, I typed this sequence of commands:
sudo su
fdisk -l
(Now I looked for the device name of the bootable partition. There is a "Boot" column with an asterix in the line corresponding to the bootable partition. In my case, it was: /dev/sda1 )
ls /mnt (to confirm that nothing was mounted in there yet)
mount /dev/sda1 /mnt
mount -t proc none /mnt/proc
mount -o bind /dev /mnt/dev
mount -o bind /sys /mnt/sys ( I added this from another help page )
chroot /mnt
source /etc/profile
(I remembered installing an updated nvidia driver with number 319, but I looked for the exact name to remove in:
System Settings > Software & Updates > Additional Drivers
There is probably a better way to find the name.)
apt-get remove nvidia-319-updates
mv xorg.conf xorg.conf_bad (Just in case. I don't know if this matters.)

Then, I restarted the computer booting to the HDD installation, tried a few random things and re-booted to confirm that it wasn't a fluke :-)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.