Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem: Neither Unity 3D nor 2D display the panel, launcher or dash (icons disappear as soon as I launch an application, but I can still hover and get a tooltip). I have tried removing and reinstalling unity, compiz and ubuntu-desktop. I am running 12.04 LTS.

I have a ATI Radeon 7000 graphics card (04:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV100 [Radeon 7000 / Radeon VE]), which should at least be able to support Unity 2D according to Compiz documentation. I'm using the open source driver since the card is not supported by the Catalyst/fglrx driver.

Running unity --reset results in the following:

$ unity --reset
WARNING: Unity currently default profile, so switching to metacity while resetting the values
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Initializing core options...done
compiz (core) - Warn: failed to receive ConfigureNotify event on 0x1a00004

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x1200002

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x1400002

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x2a000b3

Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing vpswitch options...done
Initializing snap options...done
Initializing mousepoll options...done
Initializing resize options...done
Initializing place options...done
Initializing move options...done
Initializing wall options...done
Initializing grid options...done
Initializing session options...done
Initializing gnomecompat options...done
Initializing animation options...done
Initializing fade options...done
Initializing unitymtgrabhandles options...done
Initializing workarounds options...done
Initializing scale options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing ezoom options...done

(compiz:4691): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key   (dirname, NULL)' failed
compiz (unityshell) - Error: OpenGL 1.4+ not supported

compiz (unityshell) - Error: GL_ARB_vertex_program not supported

compiz (unityshell) - Error: GL_ARB_fragment_program not supported

X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  33 (X_GrabKey)
  Serial number of failed request:  6443
  Current serial number in output stream:  6689

Any help would be much appreciated!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.