Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this error appears many times on the web, and the advice is to boot from a live CD/USB and re-install the grub from the terminal. This is not a solution for me since I am getting the error when booting from USB.

From the BIOS I have set the boot device priority to 'Removable Device'. Not sure if I should set USB to 1st Hard Disk.

error: no such device: 8d0615a7-b8ff-499f-88e0-99b323b9d524.
grub rescue>

PC: ASUS EeePC 4G.

Trying to install Lubuntu 13.04

share|improve this question
    
The error means that your hard-drive (device: 8d0615a7-b8ff-499f-88e0-99b323b9d524) is not being found. If this a new install it likely means that the fstab file was not created correctly. If it just started happening on a previously working install, then unless you just recently changed something(like updated) then it may mean your HD is failing. Please include more info: Is this a new install? If this is an old install Did you change anything in the system, just before this started happening? –  TrailRider Dec 1 '13 at 19:06
    
I'm also confused by: "From the BIOS I have set the boot device priority to rem dev. Not sure if I should set USB to 1st Hard Disk" have you selected the USB as the first boot device? Not sure what "rem dev" is... What do you mean by "Not sure if I should set USB to 1st Hard Disk" You should try to boot the USB by selecting it in the boot menu or by telling the BIOS to boot from it first. You should then be able to boot into the liveUSB and try to fix your grub from there. –  TrailRider Dec 1 '13 at 19:11
    
I have set the boot device to removable device/usb. Booting from usb gives me the grub error too, that is what I tried to initially explain. I have taken the Asus out of storage and do not remember what the last actions were that I made. –  user1575949 Dec 1 '13 at 20:04
    
If you are getting the exact same error with the USB then the USB is not being recognized by the system, otherwise the UUID number would be different. UUID is Unique Universal Identifying Device. The USB and the HD would not have the same number. It is possible that the USB is bad, try it in another computer if possible. If the USB is good then this is beyond my ability, all the ways I know to fix this need to be done from a LiveUSB. It is possible to manually load grub from the prompt but I don't know how... –  TrailRider Dec 1 '13 at 20:24
    
The USB is good, I have also tried other removable devices. "1st Hard Disk" In the BIOS under Boot > Hardisk Drives There is the option to set 1st/2nd Drives. Default is: 1st drive set to HDD. I tried: 1st drive set to USB. The install got some of the way and then stalled. Not sure if that is of any help? –  user1575949 Dec 1 '13 at 21:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.